Сообщения без ответов | Активные темы Текущее время: 23 апр 2021, 20:30



Ответить на тему  [ 1 сообщение ] 
Cisco ISR, два провайдера и проброс портов 
Автор Сообщение

Зарегистрирован: 02 дек 2020, 00:14
Сообщения: 1
Всем привет! Помогите разобраться пожалуйста.

Есть циска 2911. У нее два канала с белыми IP: ISP1 (GigabitEthernet0/1, основной) и ISP2 (Dialer0, запасной). Настроен NAT для локальной сети (GigabitEthernet0/0), IP SLA для переключения каналов при падении и local policy route-map, чтобы оба белых IP были доступны извне.

Теперь нужно пробросить с обоих белых IP порт TCP 443 на внутрунний адрес 10.0.0.10 так, чтобы проброс работал на обоих адресах вне зависимости от того, какой канал является активным. Я прописал статические правила, но работает это в итоге только для активного канала (являющегося шлюзом по умолчанию)...

Я много лет уже не работл с цисками и смутно помню, что был некий костыль через те же route maps, но воспроизвести его не смог. Может кто подсказать, где я ошибся?

Конфиг:

Код:
!
interface GigabitEthernet0/0
description ISP1
ip address 1.2.3.4 255.255.255.248
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
no cdp enable
no mop enabled
!
interface GigabitEthernet0/1
description LAN
ip address 10.0.0.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Dialer0
description ISP2
mtu 1488
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
load-interval 30
dialer pool 1
dialer-group 1
no cdp enable
!
ip local policy route-map Local
ip forward-protocol nd
!
ip nat inside source route-map ISP2 interface Dialer0 overload
ip nat inside source route-map ISP1 interface GigabitEthernet0/0 overload
ip nat inside source static tcp 10.0.0.10 443 1.2.3.4 443 route-map ISP1 extendable
ip nat inside source static tcp 10.0.0.10 443 5.6.7.8 443 route-map ISP2 extendable
ip route 0.0.0.0 0.0.0.0 1.2.3.1 10 track 10
ip route 0.0.0.0 0.0.0.0 Dialer0 30 track 30
!
ip access-list standard ISP2_IP
permit 5.6.7.8
deny any
ip access-list standard ISP1_ip
permit 1.2.3.4
deny any
!
ip sla 10
icmp-echo 8.8.8.8 source-interface GigabitEthernet0/0
threshold 40
timeout 1000
frequency 3
ip sla schedule 10 life forever start-time now
ip sla 30
icmp-echo 8.8.8.8 source-interface Dialer0
threshold 1000
timeout 1500
frequency 3
ip sla schedule 30 life forever start-time now
!
route-map ISP1 permit 10
match interface GigabitEthernet0/0
!
route-map Local permit 10
match ip address ISP1_ip
set ip next-hop 1.2.3.1
!
route-map Local permit 20
match ip address ISP2_IP
set interface Dialer0
!
route-map ISP2 permit 10
match interface Dialer0
!


Спасибо.


03 дек 2020, 00:21
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ 1 сообщение ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 10


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB