Сообщения без ответов | Активные темы Текущее время: 21 сен 2018, 05:01



Ответить на тему  [ Сообщений: 20 ] 
Задачка про маршрутизацию (от Cma1kep) 
Автор Сообщение
Супермодератор

Зарегистрирован: 01 окт 2008, 12:24
Сообщения: 4439
Есть задачка очень простая,прошу особо не пинать.

и так, есть топология из трех маршрутизаторов R1, R2, R3. Со следующими условиями
1.Между R1 и R2 настроен протокол маршрутизации EIGRP, предположим что сеть между ними - 172.16.0.0/24
2. Между R2 и R3 настроен протокол маршрутизации OSPF, предположим что сеть между ними 172.16.10/24
3.На R1 есть loopback интерфейс который участвует в протоколе EIGRP, предположим что у него адрес 192.168.1.1/24
4.На R3 есть loopback интерфейс который участвует в протоколе OSPF, предположим что у него адрес 192.168.3.1/24

Задача:
Необходимо достучаться с Loopback адреса R1 до R3 (и наоборот)
Например,
ping 192.168.3.1 so loop 0
telnet 192.168.3.1 /so loop 0

при условии что нельзя пользоваться:
1. Статической маршрутизацией на любом из маршрутизаторов
2. Редистрибуцией ( не статики, не из протокола в протокол)
3. Роут-мапами
Ну в общем задачка рассчитана на уровень CCNA

Удачи!

ЗЫ Я надеюсь, что зачинщик задачи возьмет на себя труд комментировать возможные предлагаемые решения :)


14 апр 2010, 12:12
Профиль

Зарегистрирован: 20 окт 2009, 18:55
Сообщения: 962
а Натом можно? я им подковы гнуть могу :)


14 апр 2010, 12:50
Профиль

Зарегистрирован: 20 окт 2009, 18:55
Сообщения: 962
да, на R1 и R3 подразумевается дефолт на R2 ? иначе пакет даже никуда не пойдет, умрет прям на месте.


14 апр 2010, 12:53
Профиль

Зарегистрирован: 14 июн 2009, 11:17
Сообщения: 65
Неа, дефолтных маршрутов нет не на Р1 не Р2 , ну и конечно на Р2.


14 апр 2010, 13:15
Профиль

Зарегистрирован: 14 июн 2009, 11:17
Сообщения: 65
[quote="Ilya"]а Натом можно? я им подковы гнуть могу :)[/quote]


Ну это всем известно, что ты любитель этого дела.

Как вариант решения рассмотреть НАТ можно, но есть другое решение простое.)


14 апр 2010, 13:18
Профиль

Зарегистрирован: 14 июн 2009, 11:17
Сообщения: 65
[quote="Ilya"]да, на R1 и R3 подразумевается дефолт на R2 ? иначе пакет даже никуда не пойдет, умрет прям на месте.[/quote]


Ребят, дефолтный маршрут в протоколах маршрутизации "спускать" тоже нельзя.


14 апр 2010, 13:32
Профиль

Зарегистрирован: 14 июн 2009, 11:17
Сообщения: 65
Коллеги, я прикрепил файл, что бы было более наглядно и понятно.


Вложения:
lab.jpeg
lab.jpeg [ 13.27 КБ | Просмотров: 14879 ]
15 апр 2010, 11:44
Профиль

Зарегистрирован: 08 май 2009, 16:56
Сообщения: 35
Добиться нужного эффекта можно с помощью summary

R1:

hostname R1
!
interface Loopback0
ip address 192.168.1.1 255.255.255.0
!
interface Ethernet0/0
ip address 172.16.0.1 255.255.255.0
half-duplex
!
router eigrp 1
network 172.16.0.0 0.0.0.255
network 192.168.1.0
no auto-summary


R2:

hostname R2
!
interface Loopback1
ip address 192.168.1.2 255.255.255.255
!
interface Loopback2
ip address 192.168.3.2 255.255.255.255
!
interface Ethernet0/0
ip address 172.16.0.2 255.255.255.0
ip summary-address eigrp 1 192.168.3.0 255.255.255.0 5
half-duplex
!
interface Ethernet1/0
ip address 172.16.1.2 255.255.255.0
half-duplex
!
router eigrp 1
network 172.16.0.0 0.0.0.255
network 192.168.3.0
no auto-summary
!
router ospf 1
log-adjacency-changes
area 1 range 192.168.1.0 255.255.255.0
network 172.16.1.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 1



R3:

hostname R3
!
interface Loopback0
ip address 192.168.3.1 255.255.255.0
!
interface Ethernet0/0
ip address 172.16.1.1 255.255.255.0
half-duplex
!
router ospf 1
log-adjacency-changes
network 172.16.1.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.255 area 0


15 апр 2010, 17:25
Профиль

Зарегистрирован: 14 июн 2009, 11:17
Сообщения: 65
to Lis

Да, такое вариант работает, и его можно рассмотреть как решение.
НО есть одно исключение, в рамках CCNA не рассматривается внутрезоновая маршрутизация OSPF (IA), с суммаризацией EIGRP соглашусь- она есть в CCNA.

В общем, есть еще одно решение.
P.S. IIya раскусил его примерно за пол часа)))


15 апр 2010, 22:33
Профиль
Супермодератор

Зарегистрирован: 01 окт 2008, 12:24
Сообщения: 4439
Интересно, а так сработает:

R1(config)# arp 192.168.3.1 {MAC f0/0 R2}
R3(config)# arp 192.168.1.1 {MAC f0/1 R2}


15 апр 2010, 23:11
Профиль

Зарегистрирован: 14 июн 2009, 11:17
Сообщения: 65
Щас проверю)


15 апр 2010, 23:13
Профиль

Зарегистрирован: 14 июн 2009, 11:17
Сообщения: 65
прописал, при выводе команды

R1#sh arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 192.168.3.1 - cc01.0d0b.0000 ARPA
Internet 172.16.0.1 - cc00.0d0b.0000 ARPA FastEthernet0/0
Internet 172.16.0.2 3 cc01.0d0b.0000 ARPA FastEthernet0/0

видно, что не хватает выходного интерфейса.

При указании явно интерфейса

R1(config)#arp 192.168.3.1 cc01.0d0b.0000 arpa fa0/0
Bad ARP command - Interface may only be specified when bridging IP

Р1, начинает ругаться.
Тоже самое и с Р3.


15 апр 2010, 23:20
Профиль
Супермодератор

Зарегистрирован: 01 окт 2008, 12:24
Сообщения: 4439
Хм, да, точно. Для прописывания АРПа надо было ещё указать хостовой маршрут. Спасибо что проверили. Я забыл :)


16 апр 2010, 09:12
Профиль

Зарегистрирован: 08 май 2009, 16:56
Сообщения: 35
А с ARP тоже сработает, если добавить на по одной команде на интерфейсах R1 и R3:

R1:
ip address 192.168.3.1 255.255.255.252 secondary

R3:
ip address 192.168.1.1 255.255.255.252 secondary


16 апр 2010, 18:26
Профиль

Зарегистрирован: 08 май 2009, 16:56
Сообщения: 35
Очепятался :)
следует читать: 192.168.3.2 и 192.168.1.2


16 апр 2010, 18:30
Профиль

Зарегистрирован: 14 июн 2009, 11:17
Сообщения: 65
да же не знаю, что ответить)))


16 апр 2010, 22:07
Профиль

Зарегистрирован: 14 июн 2009, 11:17
Сообщения: 65
Коллеги, добрый день!

Есть идеи еще?

В качестве подсказки у lis'а в первом посте есть часть решения которое я задумывал.
P.S. summary-address не входило в это решение.


20 апр 2010, 09:56
Профиль

Зарегистрирован: 08 май 2009, 16:56
Сообщения: 35
Варианты:

1. Настроить RIP на трех маршрутизаторах не противоречит условиям задачи и вполне укладывается в рамки CCNA :-D

2. В моей первой версии решения внести следующие исправления:

hostname R2
!
interface Loopback1
ip address 192.168.1.2 255.255.254.0
!
interface Loopback2
ip address 192.168.3.2 255.255.254.0
!
router eigrp 1
network 192.168.3.0 0.0.1.255
!
router ospf 1
network 192.168.1.0 0.0.1.255 area 0

ЗЫ На GNS3 не проверил, возможно, что и забыл :-)


20 апр 2010, 11:28
Профиль
Супермодератор

Зарегистрирован: 01 окт 2008, 12:24
Сообщения: 4439
Я думаю, что уже вполне автор может рассказать про свое, как оказалось не такое уж простое, как хотелось представить :), решение.

Одна просьба: поподробнее. Почему это заработает и для OSPF и для EIGRP


22 апр 2010, 14:24
Профиль

Зарегистрирован: 14 июн 2009, 11:17
Сообщения: 65
Друзья, добрый день!

Извиняюсь за столь долгий ответ.

и так, начнем все по порядку.
1. To Lis, идея с интерфейсом на R2 была правильной, но я немного по другому представлял свое решение :))

2. В общем идея была такова, что бы на R2 завести "суммарный" Loopback, для наглядности я использовал 192.168.0.0/16 , то есть в эту сеть попадают сети loopback адресов R1, R3.

3.Для чего мне понадобился "такой" интерфейс? Для того , что распростронить его есть по настроенным протоколам маршрутизации(OSPF, EIGRP).
Так как в EIGRP отключена автосуммаризация, то R1 будет получать маршрут с 192.168.0.0 с маской 16 который лежит через R2.

4. (Маленькое отступление)Очень важный моментом является, то какой айпи адрес присвоим на R2 loopback,так как в курсе CCNA не дается команда ip ospf network-type,т.е. сети-loopback будут прилетать с 32 маской,то как же R3 узнает о R1 loopback'e? - ответ простой, на R2 loopback'e должен быть тот же адрес, что и R1 loopbacke, с единственной разницей в маске подсети(о которой я писал в пункте 2.)

5. Ниже провожу конфиги, и дебаг для того что убедиться, что все работает)))

hostname R1
!
interface Loopback0
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.0.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 100
network 172.16.0.0 0.0.0.255
network 192.168.1.0
no auto-summary


hostname R2
!
interface Loopback0
ip address 192.168.1.1 255.255.0.0
!
interface FastEthernet0/0
ip address 172.16.0.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.1.1 255.255.255.0
duplex auto
speed auto
!
router eigrp 100
network 172.16.0.0 0.0.0.255
network 192.168.1.1 0.0.0.0
no auto-summary
!
router ospf 1
log-adjacency-changes
network 172.16.1.0 0.0.0.255 area 0
network 192.168.1.1 0.0.0.0 area 0
!



hostname R3
!
interface Loopback0
ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.1.2 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 172.16.1.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.255 area 0
!


6. Ниже таблицы маршрутизации на каждом маршрутизаторе.
R1#sh ip route
Gateway of last resort is not set

172.16.0.0/24 is subnetted, 1 subnets
C 172.16.0.0 is directly connected, FastEthernet0/0
C 192.168.1.0/24 is directly connected, Loopback0
D 192.168.0.0/16 [90/156160] via 172.16.0.2, 00:09:05, FastEthernet0/0


R2#sh ip route
Gateway of last resort is not set

172.16.0.0/24 is subnetted, 2 subnets
C 172.16.0.0 is directly connected, FastEthernet0/0
C 172.16.1.0 is directly connected, FastEthernet0/1
D 192.168.1.0/24 [90/156160] via 172.16.0.1, 00:09:36, FastEthernet0/0
192.168.3.0/32 is subnetted, 1 subnets
O 192.168.3.1 [110/2] via 172.16.1.2, 00:08:53, FastEthernet0/1
C 192.168.0.0/16 is directly connected, Loopback0

R3#sh ip route
Gateway of last resort is not set

172.16.0.0/24 is subnetted, 1 subnets
C 172.16.1.0 is directly connected, FastEthernet0/1
192.168.1.0/32 is subnetted, 1 subnets
O 192.168.1.1 [110/2] via 172.16.1.1, 00:09:36, FastEthernet0/1
C 192.168.3.0/24 is directly connected, Loopback0


7. Дебаг

R1#debug ip icmp
ICMP packet debugging is on
R1#


R3#
R3#ping 192.168.1.1 so lo0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/16/24 ms
R3#

R1#
*Mar 1 00:13:54.939: ICMP: echo reply sent, src 192.168.1.1, dst 192.168.3.1
*Mar 1 00:13:54.971: ICMP: echo reply sent, src 192.168.1.1, dst 192.168.3.1
*Mar 1 00:13:54.995: ICMP: echo reply sent, src 192.168.1.1, dst 192.168.3.1
*Mar 1 00:13:55.011: ICMP: echo reply sent, src 192.168.1.1, dst 192.168.3.1
*Mar 1 00:13:55.023: ICMP: echo reply sent, src 192.168.1.1, dst 192.168.3.1

8. Заключение.
Другими словами, пакеты с R2 будут маршрутизироваться по правилу наибольшего совпадения по маске подсети маршрута.


23 апр 2010, 13:07
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 20 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: Google [Bot] и гости: 1


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB