Сообщения без ответов | Активные темы Текущее время: 19 янв 2018, 02:38



Ответить на тему  [ Сообщений: 9 ] 
Cisco 2801 + Users 
Автор Сообщение

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 7
Добрый день!

Есть Cisco 2801 на ней есть Virtual-Template к которому подключаются юзеры. Список юзеров записан в Cisco. Есть 2 пула IP адресов ххх.ууу.90.0/23 и ххх.ууу.98.0/24.
Вопрос: как можно привязать пользователей к определенному пулу IP адресов?


12 дек 2011, 09:39
Профиль

Зарегистрирован: 16 дек 2008, 08:44
Сообщения: 581
насколько я помню (хотя конечно могу и ошибаться)

Код:
aaa attribute list #users-net-90
 attribute type addr-pool #net-90 service ppp protocol ip
aaa attribute list #users-net-98
 attribute type addr-pool #net-98 service ppp protocol ip

username user1 password 123123
username user1 aaa attribute list #users-net-90
username user2 password 123123
username user2 aaa attribute list #users-net-98


Соответственно в Virtual-Template1 надо не забыть волшебное "no peer default ip address"


12 дек 2011, 10:48
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 7
Чет не получается. Может чего то не так делаю:
Код:

!
version 12.4
hostname C2801
!
boot-start-marker
boot system flash c2801-advipservicesk9-mz.124-21.bin
boot-end-marker
!
logging buffered 51200 warnings
no logging console
!
aaa new-model
!
aaa user profile 1
!
aaa authentication login default local
aaa authentication ppp WoFNO_AAA local
aaa authorization exec default if-authenticated
aaa authorization network WoFNO_AAA if-authenticated
!
aaa attribute list Navigation_1
 attribute type addr-pool "Navigation_1" service ppp protocol ip
!
aaa session-id common
ip cef
!
!
no ip dhcp use vrf connected
!
vpdn-group 1
 description for_L2TP
 accept-dialin
  protocol l2tp
  virtual-template 1
 terminate-from hostname asd
 source-ip xxx.xxx.xxx.xxx
 local name LNS_C2801
 lcp renegotiation always
 l2tp sequencing
 l2tp tunnel password 7 passw0rd
 l2tp tunnel receive-window 600
!
username User1@tratata.ru password 7 passw0rd
username User1@tratata.ru aaa attribute list Navigation_1
!
interface Virtual-Template1
 description For_L2TP
 ip unnumbered Loopback1
 ip access-group WoFNO_pool_in in
 ip access-group WoFNO_pool_out out
 no peer default ip address
 ppp mtu adaptive proxy
 ppp authentication pap chap WoFNO_AAA
 ppp authorization WoFNO_AAA
 ppp ipcp dns xxx.xxx.3.3
!
ip local pool Navigation_1 xxx.xxx.90.1 xxx.xxx.91.254


13 дек 2011, 07:21
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 4526
addr-pool "Navigation_1" - откуда кавычки?:)


13 дек 2011, 10:07
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 3
Кавычки Cisco сама ставит.


13 дек 2011, 13:32
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 21
Попробуйте
aaa authorization network WoFNO_AAA local if-authenticated


14 дек 2011, 10:04
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 3
Да, это оно и есть.
Спасибо.
Пользователям отдаются адреса из соответствующих пулов.


15 дек 2011, 11:13
Профиль

Зарегистрирован: 16 дек 2008, 08:44
Сообщения: 581
Выложите финальный конфиг, да будем тему закрывать.


16 дек 2011, 13:41
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 3
Результирующий конфиг.
Абоненты подключаются по PPP через L2TP туннель.
В зависимости от принадлежости в настройках пользователя к aaa attribute list выдаются IP-адреса из соответствующих пулов, а также отдается адрес dns сервера. Используется в данном случае локальный AAA сервер (в отличие от внешнего RADIUS или TACACS).




version 12.4
hostname C2801
!
boot-start-marker
boot system flash c2801-advipservicesk9-mz.124-21.bin
boot-end-marker
!
logging buffered 51200 warnings
no logging console
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication ppp WoFNO_AAA local
aaa authorization exec default if-authenticated
aaa authorization network WoFNO_AAA local if-authenticated
!
aaa attribute list 1
attribute type addr-pool "Navigation_1" service ppp protocol ip
attribute type dns-servers "xxx.xxx.3.3" service ppp protocol ip
aaa attribute list 2
attribute type addr-pool "Database_1" service ppp protocol ip
attribute type dns-servers "xxx.xxx.3.3" service ppp protocol ip
!
aaa session-id common
ip cef
!
!
no ip dhcp use vrf connected
!
vpdn-group 1
description for_L2TP
accept-dialin
protocol l2tp
virtual-template 1
terminate-from hostname asd
source-ip xxx.xxx.xxx.xxx
local name LNS_C2801
lcp renegotiation always
l2tp sequencing
l2tp tunnel password 7 passw0rd
l2tp tunnel receive-window 600
!
username User1 password 7 passw0rd
username User1 aaa attribute list 1
username User2 password 7 passw0rd
username User2 aaa attribute list 2
!
interface Virtual-Template1
description For_L2TP
ip unnumbered Loopback1
no peer default ip address
ppp mtu adaptive proxy
ppp authentication pap chap WoFNO_AAA
ppp authorization WoFNO_AAA
!
ip local pool Navigation_1 xxx.xxx.90.1 xxx.xxx.91.254
ip local pool Database_1 xxx.xxx.95.1 xxx.xxx.95.254


19 дек 2011, 06:49
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 9 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB