Сообщения без ответов | Активные темы Текущее время: 12 дек 2019, 17:43



Ответить на тему  [ Сообщений: 7 ] 
site to site vpn asa 5505 routing problem 
Автор Сообщение

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 21
Всем доброго времени суток.
Имеется следующая схема:

192.168.239.0/24---(sonicwall)172.20.20.1---172.20.20.2(asa 5505)public_ip1===public_ip2(cisco)---10.1.150.0/24

Собственно, настроен vpn между asa 5505 public_ip1 и cisco public_ip2.
VPN поднимается в случае: 172.20.20.0/24-> 10.1.150.0/24
На sonicwall включен NAT: 192.168.239.0/24 -> 172.20.20.1/24
Проблема заключается в том, что при попытке пропинговать к примеру с хоста 192.168.239.250 хост 10.1.150.1 фаервол asa 5505 получает arp запросы:


arp-in: request at inside from 172.20.20.1 0006.b127.3317 for 10.1.150.1 0000.0000.0000
arp-set: added arp inside 172.20.20.1 0006.b127.3317 and updating NPs at 34794710
arp-in: request at inside from 172.20.20.1 0006.b127.3317 for 10.1.150.1 0000.0000.0000
arp-set: added arp inside 172.20.20.1 0006.b127.3317 and updating NPs at 34794750
arp-in: request at inside from 172.20.20.1 0006.b127.3317 for 10.1.150.1 0000.0000.0000
arp-set: added arp inside 172.20.20.1 0006.b127.3317 and updating NPs at 34794800

но в ответ ничего не отправляет.
Т.е получается asa 5505 не знает, что делать с подсеткой 10.1.150.0
Вот что ловит capture:

15: 16:16:25.235842 802.1Q vlan#1 P0 arp who-has 10.1.150.1 tell 172.20.20.1
16: 16:16:25.277802 802.1Q vlan#1 P0 arp who-has 10.1.150.1 tell 172.20.20.1
17: 16:16:25.327802 802.1Q vlan#1 P0 arp who-has 10.1.150.1 tell 172.20.20.1

vpn настроен правильно, потому что после выполнения команды:
packet-tracer input inside icmp 172.20.20.1 0 0 10.1.150.1
соединение устанавливается.

Конфиг asa 5505:

ASA Version 8.2(1)
!
hostname ciscoasa
enable blablabla
passwd blablabla
names
!
interface Vlan1
nameif inside
security-level 100
ip address 172.20.20.2 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address public_ip1 255.255.255.240
!
interface Vlan5
no forward interface Vlan1
nameif dmz
security-level 50
no ip address
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
same-security-traffic permit intra-interface
access-list inside_access_in extended permit ip any any
access-list outside_access_in extended permit ip any any
access-list outside_access_in extended permit tcp any any eq ssh
access-list nonat extended permit ip 172.20.20.0 255.255.255.0 10.1.150.0 255.255.255.0
access-list 110 extended permit ip 172.20.20.0 255.255.255.0 10.1.150.0 255.255.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 gw_ip 1
route inside 192.168.239.0 255.255.255.0 172.20.20.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication enable console LOCAL
aaa authentication ssh console LOCAL
aaa authorization command LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
http 172.20.20.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
sysopt nodnsalias inbound
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set dell-dc esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map dell-dc 10 match address 110
crypto map dell-dc 10 set pfs
crypto map dell-dc 10 set peer public_ip2
crypto map dell-dc 10 set transform-set dell-dc
crypto map dell-dc interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 30
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 30
console timeout 0
dhcpd auto_config outside
!

threat-detection basic-threat
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
username blablabla
username blablabla
tunnel-group public_ip2 type ipsec-l2l
tunnel-group public_ip2 ipsec-attributes
pre-shared-key *

Может кто сталкивался с такой проблемой или есть советы как можно траблшутить проблему?


17 фев 2011, 03:35
Профиль
Супермодератор

Зарегистрирован: 01 окт 2008, 12:24
Сообщения: 4436
Мне не нравится, что СоникВолл шлет АРП на 10.1.150.1 ПО идее он должен слать АРП-запрос на 172.20.20.2, т.к. это шлюз.

С самого СоникВолла тоже не пингается 10.1.150.х?

А какая на нем таблица маршрутизации?


17 фев 2011, 08:04
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 21
он шлет arp не на 10.1.150.1, он шлет их на 172.20.20.2.
С SonicWall ip 10.1.150.1 не пингуется.

маршрут на SonicWall: 10.1.150.0/24 -> 172.20.20.2


17 фев 2011, 08:20
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 1834
Если он шлет такие ARP, значит этот маршрут не работает.

diezzz писал(а):
маршрут на SonicWall: 10.1.150.0/24 -> 172.20.20.2


17 фев 2011, 09:41
Профиль ICQ

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 21
Lomax писал(а):
Если он шлет такие ARP, значит этот маршрут не работает.

diezzz писал(а):
маршрут на SonicWall: 10.1.150.0/24 -> 172.20.20.2


thnx Lomax). действительно, я не правельно настроил маршрут.


17 фев 2011, 10:30
Профиль
Супермодератор

Зарегистрирован: 01 окт 2008, 12:24
Сообщения: 4436
Ура, угадали.

ДУмаю, что было написано
10.1.150.0/24->172.20.20.1

Сейчас починилось?


17 фев 2011, 10:43
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 21
Fedia писал(а):
Сейчас починилось?

Да, спасибо)
gw был выставлен другой.


17 фев 2011, 11:27
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 7 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB