Сообщения без ответов | Активные темы Текущее время: 11 дек 2019, 07:10



Ответить на тему  [ Сообщений: 8 ] 
Проблема редистрибуции маршрутов между OSPF и EIGRP 
Автор Сообщение

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 2111
Добрый день.
На маршрутизаторе есть 2 процесса маршрутизации.
Необходимо настроить взаимную редистрибуцию маршрутов между ними.

router eigrp 1
redistribute ospf 1
passive-interface default
no passive-interface Tunnel1
network 172.22.255.128 0.0.0.15
no auto-summary
eigrp router-id 3.3.3.3
!
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
area 99 authentication message-digest
redistribute eigrp 1 subnets
passive-interface default
no passive-interface GigabitEthernet0/1.2551
network 172.22.255.0 0.0.0.15 area 99

Редистрибуция EIGRP в OSPF проходит замечательно, и show ip ospf database
отображает импортированные сети.
Редистрибуция OSPF в EIGRP ни в какую не хочет рабтать.
show ip eigrp topology - пуста.

При этом если сделать редистрибуцию статики - все замечательно работает. А OSPF импортировать не хочет(

В чем может быть проблема?


15 мар 2011, 17:44
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 2111
Разобрался.
Необходимо было явно указать метрику в параметрах редистрибуции.

Почему то в учебнике по CCNP 4-й версии приводится заведомо не рабочий конфиг. Он меня и ввел в заблуждение.


15 мар 2011, 18:14
Профиль

Зарегистрирован: 20 окт 2009, 18:55
Сообщения: 962
P@ve1 писал(а):
Разобрался.
Необходимо было явно указать метрику в параметрах редистрибуции.

Почему то в учебнике по CCNP 4-й версии приводится заведомо не рабочий конфиг. Он меня и ввел в заблуждение.

если метрику не указать, то она ставится дефолтной. для EIGRP - infinity.


15 мар 2011, 22:37
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 4526
Покажи правильный конфиг :)


16 мар 2011, 09:39
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 2111
Рабочий конфиг:

router eigrp 1
redistribute ospf 1 metric 10000 100 255 1 1400 match internal

match internal - соответсвенно опционально.
А без прописания явно метрики для импорта маршрутов - работать точно не будет.


16 мар 2011, 10:26
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 4526
В CCNA про редистрибьюцию есть )


16 мар 2011, 10:42
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 2111
imperorr писал(а):
В CCNA про редистрибьюцию есть )


Когда я сдавал - не было. Не считая redistribute static. Да и не думаю, что стоит этим учебником для начинающих пользоваться)


16 мар 2011, 10:46
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 2111
Уважаемые модераторы, тему полагаю можно закрывать, как решенную.


17 мар 2011, 09:57
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 8 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB