Сообщения без ответов | Активные темы Текущее время: 11 дек 2019, 07:07



Ответить на тему  [ Сообщений: 7 ] 
IPTV, multicast схемы построения сети 
Автор Сообщение

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 34
Откуда: Омск
Добрый день.

Возникла задача раздать IPTV, предоставленный провайдером внутрь сети конторы. В данный момент в рамках тестирования IPTV приходит отдельным access портом, в котором по DHCP раздаются адреса (также возможно получить их и статикой), собственно при подключении компа или ТВ-приставки проблем не возникает, все работает.

Для начала кратко опишу структуру сети (если будет необходимо сделаю картинку): рутер 7204 GE0/0 вланами на двух провайдеров (BGP, AS, блок /22 PI-адресов), GE0/1 внутрь сети access портом на каталист 3560Е (пока используется просто как L2 свич) на него же тоже access портами идут несколько разных серверов и NAS (Freebsd+MPD5). Между серверами NAS и 3845 ходит RIP v2 (исторически сложилось, можно заменить, но вопрос надо ли...) реализовано с помощью quagga.
Далее подробнее внутри сети: за NAS 2 свича (2 отдельные сетевухи, каждая транком с пачкой вланов) 1-й Dlink dgs3100 для оптических линков, 2-й cisco 2960-48 для медных линков, за ними по разным корпусам, этажам, зданиям раскидана куча Rubytech es2126 и es2310c.
В сумме за NAS 45 вланов, все компы получают доступ в Инет по РРРоЕ, локалки как таковой нет и считается что не нужно, хотя кому необходимо в рамках своего влана (иногда это оказывается один свич) могут сделать, порты в этом случае не изолируются.

Теперь собственно основной вопрос, как бы более правильно и в тоже время не сильно ломая существующую структуру сети раздать всем желающим IPTV. В первую очередь хотелось бы именно понять как можно правильно построить схему в рамках данной сети и можно ли это вообще, если же нельзя, то в каком направлении надо изменять структуру сети. Буду очень рад ссылки на ресурсы по этой теме, а также примерам схем сети.

Еще раз замечу, цель именно раздать IPTV от провайдера внутрь сети, у нас самих нет и не планируется стримера и т.п. устройств для самостоятельного приема и обработки видео потоков.


11 окт 2011, 12:48
Профиль ICQ

Зарегистрирован: 02 июл 2009, 00:43
Сообщения: 302
Теоретически наверное можно. Хотя за успех поручиться нельзя.
Насколько я понял из описания не раскрыта тема 3845.

Смотреть например:

http://cisco-users.org/zips/20090603_DF ... ticast.pdf
http://www.cost290.org/td2004/tds/td04010.pdf

Курить в основном PIM на FreeBSD.

ЗЫ - я бы выкинул freebsd (pppoe).


11 окт 2011, 14:02
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 34
Откуда: Омск
3845 это досадная опечатка, не понимаю откуда оно взялось :) там 7204 должно быть.


12 окт 2011, 06:52
Профиль ICQ

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 34
Откуда: Омск
Прочитал немного теории, теперь необходим небольшой толчок в практическом вопросе:

Имеем multicast поток (300Мбит) с кучей каналов приходящий на порт gi 0/1 cisco 3560Е:

c3560e#show int gi 0/1
...
5 minute input rate 305046000 bits/sec,

Настройки порта такие:
c3560e#sh run int gi 0/1
!
interface GigabitEthernet0/1
switchport access vlan 10
switchport mode access
spanning-tree portfast
end

в порт gi 0/21 включен свич cisco 2960-48 порт настроен так:

c3560e#sh run int gi 0/21
!
interface GigabitEthernet0/21
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,20,30
switchport mode trunk
end

На 2960-48 vlan 20,30 access портами уходят к пользователям, а порт gi 0/1 в c3560e
2960-48#sh run int gi 0/1
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,20,30
switchport mode trunk
end

Задача, как дать возможность пользователям в vlan20,30 на свиче 2960-48 смотреть IPTV приходящее в vlan10 на c3560e.
С помощью MVR мне удалось это сделать, НО при этом на портах связывающих 2960-48 и c3560e дублируется весь поток приходящий в порт gi 0/1 c3560e, что меня немного пугает... Существует ли вообще другое решение, если да, то огромная просьба помочь разобраться, ссылки на доки приветствуются, а примерам исходя их простейшей схемы выше буду просто очень рад.


14 окт 2011, 11:27
Профиль ICQ

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 34
Откуда: Омск
Неужели нет спецов в этих вопросах...


17 окт 2011, 06:37
Профиль ICQ

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 34
Откуда: Омск
Чтож, помощи я так и не дождался, разобрался сам, ниже примеры конфигов (исходя из описания условий задачи выше) минимально необходимых чтобы заработало, для 2-х вариантов с MVR и PIM и некоторые небольшие пояснения, может кому пригодится в будущем.

1. вариант с MVR

cisco 3560e:

ip igmp snooping
mvr
mvr vlan 10
mvr group 239.10.0.1
mvr group 239.10.0.2
...
mvr group 239.10.0.72

interface GigabitEthernet0/1
switchport access vlan 10
switchport mode access
mvr type source
spanning-tree portfast

interface GigabitEthernet0/21
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10
switchport mode trunk
mvr type source

cisco 2960:

ip igmp snooping

interface FastEthernet0/1
switchport access vlan 20
switchport mode access
mvr type receiver
spanning-tree portfast

interface FastEthernet0/2
switchport access vlan 30
switchport mode access
mvr type receiver
spanning-tree portfast

interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10
switchport mode trunk
mvr type source

Тут стоит обратить внимание на то, что на портах Gi 0/21 и Gi 0/1 связывающих 3560e и 2960 стоит именно mvr type source т.к. порты между свичами транковые. Между портами Gi 0/21 и Gi 0/1 свичей постоянно ходит весь поток каналов (300 Мбит), а на 2960 на клиентских портах уже только тот, который запрошен клиентом. В этой схеме остался не рассмотренным вопрос с свичами НЕ cisco вместо 2960, по идее d-link, но только те, что с возможностями ISM vlan должны тоже работать, но не было под рукой чтобы проверить.

2. вариант с PIM

cisco 3560e:

ip routing
ip multicast-routing distributed

interface GigabitEthernet0/1
no switchport
ip address 10.10.221.1 255.255.255.252
ip pim sparse-dense-mode
spanning-tree portfast
!
interface GigabitEthernet0/21
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 20,30
switchport mode trunk
!
interface Vlan20
ip address 10.10.221.9 255.255.255.252
ip pim passive
!
interface Vlan30
ip address 10.10.221.13 255.255.255.252
ip pim passive
!
interface Vlan600
description Management Vlan
ip address 10.10.10.2 255.255.255.252
!
ip pim rp-address 10.10.221.2 51 override
ip route 0.0.0.0 0.0.0.0 10.10.10.1

access-list 51 permit 239.10.0.0 0.0.0.127

cisco 2960:

ip igmp snooping

interface FastEthernet0/1
switchport access vlan 20
switchport mode access
spanning-tree portfast

interface FastEthernet0/2
switchport access vlan 30
switchport mode access
spanning-tree portfast

interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 20,30
switchport mode trunk

В строке ip pim rp-address адрес 10.10.221.2 это не ошибка, так и надо. Фактически в данной схеме вместо 2960 может быть любой другой управляемый свич с поддержкой igmp snooping, например d-link 3100, rubytech 2310c или 2126 вполне работают. Также стоит учесть, что одинаковые каналы в рамках одного vlan передаются между свичами в одном экземпляре, а вот если одинаковый канал запросят с нескольких разных vlan, то между свичами пойдет количество одинаковых потоков одного канала равное количеству vlan с которых их запросили.


18 окт 2011, 12:14
Профиль ICQ
Супермодератор

Зарегистрирован: 01 окт 2008, 12:24
Сообщения: 4436
Спасибо, что поделились Вашими достижениями.

Видимо, действительно не оказалось в нужный момент нужных знаний для Вас у нас.


23 окт 2011, 21:54
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 7 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB