Сообщения без ответов | Активные темы Текущее время: 22 окт 2018, 17:52



Ответить на тему  [ Сообщений: 5 ] 
Один вопрос про проброс портов. 
Автор Сообщение

Зарегистрирован: 19 фев 2018, 11:01
Сообщения: 21
Доброго времени суток.

Прошу помощи, ибо самому знаний явно не достаточно.
Дано: маршрутизатор с 2мя интерфейсами с внешними IP от разных провайдеров.
Необходимо: пробросить порт, чтобы использовать его можно было как с одного, так и с другого провайдера.

Проблема в том, что ip nat inside source static позволяет пробросить лишь для одного входящего интерфейса, и при попытке пробросить порт с другого, просто заменяет существующую команду.
Что я делаю не так? Вот конфиг:


version 15.7
service timestamps debug datetime msec
service timestamps log datetime
service password-encryption
!
hostname GW-2
!
boot-start-marker
boot system flash:c2900-universalk9-mz.SPA.157-3.M.bin
boot-end-marker
!
!
enable secret 4 TUSecaMQVOEFXkqTWjRu6UIyd6LZ6J5hNhJZvxeq5S2
!
aaa new-model
!
!
!
!
!
!
!
aaa session-id common
clock timezone UTC 5 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!


!
!
!
!
ip domain name surgut.sibcar.ru
ip name-server 10.3.5.201
ip name-server 8.8.8.8
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-2022597359
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2022597359
revocation-check none
rsakeypair TP-self-signed-2022597359
!
!
crypto pki certificate chain TP-self-signed-2022597359
voice-card 0
!
!
!
!
!
!
!
!
license udi pid CISCO2911/K9 sn JTV1804TCB8
license accept end user agreement
license boot module c2900 technology-package securityk9
license boot module c2900 technology-package uck9
license boot module c2900 technology-package datak9
!
!
username r-adm privilege 15 secret 4 ERGTX.e2FhvLbGgeEN2F9rqQUUDsrBcLlZtPGOLkrUI
!
redundancy
!
!
!
!
!
track 1 ip sla 1 reachability
!
track 2 ip sla 2 reachability
!
track 3 ip sla 3 reachability
!
track 4 list boolean or
object 1
object 2
object 3
delay down 10 up 5
!
!
!
!
!
!
!
bridge irb
!
!
!
!
interface Loopback0
ip address 10.10.10.10 255.255.255.0
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description LAN_B-TelePlus-LAN_N
ip address 192.168.0.2 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.255.3.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1.31
description Switches
encapsulation dot1Q 31
ip address 10.3.1.1 255.255.255.0
!
interface GigabitEthernet0/1.32
encapsulation dot1Q 32
ip address 10.3.2.1 255.255.255.0
!
interface GigabitEthernet0/1.33
encapsulation dot1Q 33
ip address 10.3.3.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/1.35
encapsulation dot1Q 35
ip address 10.3.5.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/1.327
encapsulation dot1Q 327
bridge-group 3
!
interface GigabitEthernet0/2
description LAN_P
ip address 10.255.2.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/2.21
description Switches
encapsulation dot1Q 21
ip address 10.2.1.1 255.255.255.0
!
interface GigabitEthernet0/2.22
encapsulation dot1Q 22
ip address 10.2.2.1 255.255.255.0
!
interface GigabitEthernet0/2.23
encapsulation dot1Q 23
ip address 10.2.3.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/2.327
encapsulation dot1Q 327
bridge-group 3
!
interface FastEthernet0/0/0
description LAN_B_RTC_LAN_N
ip address 172.16.0.2 255.255.255.248
ip ospf network point-to-point
duplex auto
speed auto
!
interface FastEthernet0/0/1
description Tele+
bandwidth 50000
ip address 1.1.1.1 255.255.255.255
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface FastEthernet0/1/0
description TP-Link
ip address 172.27.27.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface FastEthernet0/1/1
description RTK
ip address 2.2.2.2 255.255.255.255
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface BVI3
no ip address
!
!
ip local policy route-map echo_rm
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip dns server
ip nat inside source static tcp 10.3.5.203 3389 interface FastEthernet0/0/1 8881
ip nat inside source static tcp 10.3.5.204 3389 interface FastEthernet0/0/1 8882
ip nat inside source static tcp 10.3.5.203 8070 interface FastEthernet0/0/1 8070
ip nat inside source static tcp 10.3.5.206 3389 interface FastEthernet0/0/1 7788
ip nat inside source static tcp 10.3.3.208 3389 interface FastEthernet0/0/1 8787
ip nat inside source static tcp 10.3.5.214 80 interface FastEthernet0/0/1 55555
ip nat inside source static tcp 10.3.3.207 3389 interface FastEthernet0/0/1 54545
ip nat inside source static tcp 10.3.3.205 3389 interface FastEthernet0/0/1 45454
ip nat inside source static tcp 172.27.27.30 5050 interface FastEthernet0/0/1 5050
ip nat inside source static tcp 172.27.27.30 5051 interface FastEthernet0/0/1 5051
ip nat inside source static tcp 172.27.27.30 5052 interface FastEthernet0/0/1 5052
ip nat inside source static tcp 172.27.27.30 5053 interface FastEthernet0/0/1 5053
ip nat inside source static udp 172.27.27.30 5050 interface FastEthernet0/0/1 5050
ip nat inside source static udp 172.27.27.30 5051 interface FastEthernet0/0/1 5051
ip nat inside source static udp 172.27.27.30 5052 interface FastEthernet0/0/1 5052
ip nat inside source static udp 172.27.27.30 5053 interface FastEthernet0/0/1 5053
ip nat inside source static tcp 10.3.3.44 3389 interface FastEthernet0/0/1 9999
ip nat inside source static tcp 10.3.5.214 3389 interface FastEthernet0/0/1 8884
ip nat inside source route-map RTK interface FastEthernet0/1/1 overload
ip nat inside source route-map Tele+ interface FastEthernet0/0/1 overload
ip route 0.0.0.0 0.0.0.0 GW1 track 4
ip route 0.0.0.0 0.0.0.0 GW2 100
ip route 8.8.8.8 255.255.255.255 GW1
ip route 10.1.0.0 255.255.0.0 172.16.0.1
ip route 77.88.8.8 255.255.255.255 GW1
ip route 94.100.180.200 255.255.255.255 GW1
ip route 172.26.26.0 255.255.255.0 172.16.0.1
ip route 192.168.0.0 255.255.255.0 172.16.0.1
ip ssh server algorithm encryption aes128-ctr aes192-ctr aes256-ctr
ip ssh client algorithm encryption aes128-ctr aes192-ctr aes256-ctr
!
ip access-list standard SSH_ACCESS
permit 10.1.0.0 0.0.255.255
permit 10.2.0.0 0.0.255.255
permit 10.3.0.0 0.0.255.255
deny any
!
ip access-list extended NAT
permit ip 10.2.0.0 0.0.255.255 any
permit ip 10.3.0.0 0.0.255.255 any
permit ip 172.27.27.0 0.0.0.255 any
deny ip any any
ip access-list extended echo_check
permit icmp any host 8.8.8.8 echo
permit icmp any host 94.100.180.200 echo
permit icmp any host 77.88.8.8 echo
!
ip sla 1
icmp-echo 8.8.8.8 source-ip 1.1.1.1
request-data-size 32
frequency 15
ip sla schedule 1 life forever start-time now
ip sla 2
icmp-echo 77.88.8.8 source-ip 1.1.1.1
request-data-size 32
frequency 15
ip sla schedule 2 life forever start-time now
ip sla 3
icmp-echo 94.100.180.200 source-ip 1.1.1.1
request-data-size 32
frequency 15
ip sla schedule 3 life forever start-time now
logging host 10.3.5.202
ipv6 ioam timestamp
!
route-map Tele+ permit 10
match ip address NAT
match interface FastEthernet0/0/1
!
route-map echo_rm permit 10
match ip address echo_check
set ip next-hop GW1
!
route-map RTK permit 10
match ip address NAT
match interface FastEthernet0/1/1
!
!
!
!
!
control-plane
!
bridge 3 domain 3
bridge 3 priority 0
bridge 3 protocol ieee
bridge 3 route ip
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
vstack
!
line con 0
password 7 133D3A332414527D723438
line aux 0
exec-timeout 0 0
no activation-character
no editing
transport input telnet
transport output none
escape-character NONE
stopbits 1
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
exec-timeout 30 0
password 7 023E297A241E5976155E19
logging synchronous
transport input ssh
line vty 5 1114
exec-timeout 30 0
password 7 023E297A241E5976155E19
logging synchronous
transport input ssh
!
scheduler allocate 20000 1000
ntp source FastEthernet0/0/1
ntp master 2
ntp update-calendar
ntp server time.google.com
ntp server time.windows.com
event manager applet Link
event track 4 state any
action 10 wait 10
action 15 cli command "enable"
action 20 cli command "clear ip nat translation *"
!
end


16 апр 2018, 06:14
Профиль Отправить email

Зарегистрирован: 10 окт 2012, 09:51
Сообщения: 2569
наверное указываете все время один интерфейс


16 апр 2018, 06:24
Профиль

Зарегистрирован: 19 фев 2018, 11:01
Сообщения: 21
crash писал(а):
наверное указываете все время один интерфейс



Нет, из общего только внутренний IP и порт. Внешние интерфейс и порт указываю разные. В моем случае f0/0/1 и f0/1/1 должны быть. Но заменяются, сволочи. Не могу понять в какую сторону смотреть

Нужно чтобы было:
ip nat inside source static tcp 10.3.3.205 3389 interface FastEthernet0/0/1 45454
ip nat inside source static tcp 10.3.3.205 3389 interface FastEthernet0/1/1 45444

А на практике либо одна настройка, либо другая.


16 апр 2018, 06:31
Профиль Отправить email

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 773
попробуйте через loopback +pbr
вот здесь обсуждение на эту тему https://supportforums.cisco.com/t5/wan- ... -p/1610915


17 апр 2018, 08:48
Профиль

Зарегистрирован: 19 фев 2018, 11:01
Сообщения: 21
aliotru писал(а):
попробуйте через loopback +pbr
вот здесь обсуждение на эту тему https://supportforums.cisco.com/t5/wan- ... -p/1610915



Спасибо ) Всё оказалось значительно проще. Достаточно было вместо интерфейса указать IP и добавить extendable, и всё работает.

Спасибо за ссылочку )


18 апр 2018, 06:15
Профиль Отправить email
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 5 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: Google Adsense [Bot] и гости: 18


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB