Сообщения без ответов | Активные темы Текущее время: 17 дек 2018, 00:53



Ответить на тему  [ Сообщений: 10 ] 
cisco unnumbered + quagga ospfd 
Автор Сообщение

Зарегистрирован: 02 янв 2014, 13:32
Сообщения: 81
Есть циска и роутер на линуксе, между ними поднят GRE-туннель. Если в туннеле прописать связную линковочную сеть, то OSPF поднимается и все ок, а если на циске использовать unnumbered и сеть внутри gre оказывается не связная (например на концах используются адресе с /32 маской), то нифика не работает:

Конфа на циске:
Код:
interface Loopback2
 ip address 172.17.255.0 255.255.255.255
 ip ospf network point-to-point

interface Tunnel101
 ip unnumbered Loopback2
 ip mtu 1400
 ip ospf mtu-ignore
 tunnel source Loopback2
 tunnel destination 172.17.255.1

router ospf 100
 router-id 192.168.1.1
 prefix-suppression
 passive-interface default
 no passive-interface Tunnel101
... лишние сети опущены ...
 network 172.17.255.0 0.0.0.0 area 0


про соседа говорит вот что:
Код:
sh ip ospf neighbor 172.17.255.1
 Neighbor 172.17.255.1, interface address 172.17.255.1
    In the area 0 via interface Tunnel101
    Neighbor priority is 0, State is INIT, 1 state changes
    DR is 0.0.0.0 BDR is 0.0.0.0
    Options is 0x0 in Hello
    Dead timer due in 00:00:33
    Index 0/0/0, retransmission queue length 0, number of retransmission 0
    First 0x0(0)/0x0(0)/0x0(0) Next 0x0(0)/0x0(0)/0x0(0)
    Last retransmission scan length is 0, maximum is 0
    Last retransmission scan time is 0 msec, maximum is 0 msec


дебаг на циске:
Код:
May  8 2018 22:21:20: OSPF-100 HELLO Tu101: Send hello to 224.0.0.5 area 0 from 0.0.0.0
May  8 2018 22:21:20: OSPF-100 PAK  : Tu101: OUT: 0.0.0.0->224.0.0.5: ver:2 type:1 len:44 rid:192.168.1.1 area:0.0.0.0 chksum:29F6 auth:0
ESKO-main-gw#
May  8 2018 22:21:22: OSPF-100 PAK  : Tu101:  IN: 172.17.255.1->224.0.0.5: ver:2 type:1 len:44 rid:172.17.255.1 area:0.0.0.0 chksum:508C auth:0
May  8 2018 22:21:22: OSPF-100 HELLO Tu101: Rcv hello from 172.17.255.1 area 0 172.17.255.1
May  8 2018 22:21:22: OSPF-100 HELLO Tu101: Send immediate hello to nbr 172.17.255.1, src address 172.17.255.1
May  8 2018 22:21:22: OSPF-100 HELLO Tu101: Send hello to 224.0.0.5 area 0 from 0.0.0.0
May  8 2018 22:21:22: OSPF-100 PAK  : Tu101: OUT: 0.0.0.0->224.0.0.5: ver:2 type:1 len:48 rid:192.168.1.1 area:0.0.0.0 chksum:7EDE auth:0
ESKO-main-gw#
May  8 2018 22:21:30: OSPF-100 HELLO Tu101: Send hello to 224.0.0.5 area 0 from 0.0.0.0
May  8 2018 22:21:30: OSPF-100 PAK  : Tu101: OUT: 0.0.0.0->224.0.0.5: ver:2 type:1 len:48 rid:192.168.1.1 area:0.0.0.0 chksum:7EDE auth:0
ESKO-main-gw#
May  8 2018 22:21:32: OSPF-100 PAK  : Tu101:  IN: 172.17.255.1->224.0.0.5: ver:2 type:1 len:44 rid:172.17.255.1 area:0.0.0.0 chksum:508C auth:0
May  8 2018 22:21:32: OSPF-100 HELLO Tu101: Rcv hello from 172.17.255.1 area 0 172.17.255.1
May  8 2018 22:21:32: OSPF-100 HELLO Tu101: Send immediate hello to nbr 172.17.255.1, src address 172.17.255.1
May  8 2018 22:21:32: OSPF-100 HELLO Tu101: Send hello to 224.0.0.5 area 0 from 0.0.0.0
May  8 2018 22:21:32: OSPF-100 PAK  : Tu101: OUT: 0.0.0.0->224.0.0.5: ver:2 type:1 len:48 rid:192.168.1.1 area:0.0.0.0 chksum:7EDE auth:0
ESKO-main-gw#
May  8 2018 22:21:40: OSPF-100 HELLO Tu101: Send hello to 224.0.0.5 area 0 from 0.0.0.0
May  8 2018 22:21:40: OSPF-100 PAK  : Tu101: OUT: 0.0.0.0->224.0.0.5: ver:2 type:1 len:48 rid:192.168.1.1 area:0.0.0.0 chksum:7EDE auth:0
ESKO-main-gw#
May  8 2018 22:21:42: OSPF-100 PAK  : Tu101:  IN: 172.17.255.1->224.0.0.5: ver:2 type:1 len:44 rid:172.17.255.1 area:0.0.0.0 chksum:508C auth:0
May  8 2018 22:21:42: OSPF-100 HELLO Tu101: Rcv hello from 172.17.255.1 area 0 172.17.255.1
May  8 2018 22:21:42: OSPF-100 HELLO Tu101: No more immediate hello for nbr 172.17.255.1, which has been sent on this intf 2 times



на линухе интерфейс:
Код:
 ifconfig gre1
gre1      Link encap:UNSPEC  HWaddr AC-11-FF-01-00-00-00-00-00-00-00-00-00-00-00-00
          inet addr:172.17.255.1  P-t-P:172.17.255.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP  MTU:1476  Metric:1
          RX packets:139 errors:0 dropped:0 overruns:0 frame:0
          TX packets:130 errors:14 dropped:0 overruns:0 carrier:14
          collisions:0 txqueuelen:0
          RX bytes:11116 (10.8 KiB)  TX bytes:8840 (8.6 KiB)


конфа квагги:
Код:
Current configuration:
!
password zebra
!
!
!
interface 3g-sim1
!
interface br-lan
!
interface eth0
!
interface eth0.1
!
interface gre0
!
interface gre1
 ip ospf mtu-ignore
!
interface gretap0
!
interface ifb0
!
interface ifb1
!
interface ip_vti0
!
interface lo
!
interface ppp0
!
interface wlan0
!
router ospf
 log-adjacency-changes detail
 network 172.17.0.0/28 area 0.0.0.0
 network 172.17.255.1/32 area 0.0.0.0
!
access-list vty permit 127.0.0.0/8
access-list vty deny any
!
line vty
 access-class vty
!
end


куда копать? может кто сталкивался?


08 май 2018, 22:31
Профиль Отправить email

Зарегистрирован: 21 май 2017, 20:13
Сообщения: 25
Yacudzer писал(а):
если на циске использовать unnumbered и сеть внутри gre оказывается не связная (например на концах используются адресе с /32 маской), то нифика не работает:


А должно?


09 май 2018, 00:29
Профиль

Зарегистрирован: 02 янв 2014, 13:32
Сообщения: 81
strabbo писал(а):
Yacudzer писал(а):
если на циске использовать unnumbered и сеть внутри gre оказывается не связная (например на концах используются адресе с /32 маской), то нифика не работает:

А должно?


Конечно! циска + циска отлично работает...


10 май 2018, 08:37
Профиль Отправить email

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 1780
Ищите способ настроить unnumbered в Linux/quagga


10 май 2018, 10:46
Профиль ICQ

Зарегистрирован: 02 янв 2014, 13:32
Сообщения: 81
Lomax писал(а):
Ищите способ настроить unnumbered в Linux/quagga

Спасибо, кэп. А он есть, этот способ? И нужно ли его искать? Просто ip с маской /32 удается повесить без проблем, при этом работает только статика.

Собственно, я сообщение написал в надежде на то, что у кого то уже был опыт...


10 май 2018, 10:51
Профиль Отправить email

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 1780
я бы порекомендовал сделать ip unnumbered отличный от tunnel source , c обоих сторон.


10 май 2018, 15:52
Профиль ICQ

Зарегистрирован: 02 янв 2014, 13:32
Сообщения: 81
Lomax писал(а):
я бы порекомендовал сделать ip unnumbered отличный от tunnel source , c обоих сторон.

Это не имеет значения. Проверено, делали уже. Соседство с кваггой поднимается только при наличии единой сети на интерфейсах gre. А хотелось бы использовать unnumbered, что бы в последствии использовать virtual-template.


10 май 2018, 15:57
Профиль Отправить email

Зарегистрирован: 21 май 2017, 20:13
Сообщения: 25
Yacudzer писал(а):
Lomax писал(а):
я бы порекомендовал сделать ip unnumbered отличный от tunnel source , c обоих сторон.

Это не имеет значения. Проверено, делали уже. Соседство с кваггой поднимается только при наличии единой сети на интерфейсах gre. А хотелось бы использовать unnumbered, что бы в последствии использовать virtual-template.

Я поэтому и спрашивал, должно ли так работать, потому что всегда рукуводствовался этими правилами, которые в оффициальных книгах от циски, может в книгах они пишут одно, а реализуют по другому.
Это из одной из книг, где говорится, что соседи должны быть в одной сети


Вложения:
Комментарий к файлу: Соседство оспф
ospf.GIF
ospf.GIF [ 21.07 КБ | Просмотров: 1352 ]
10 май 2018, 16:57
Профиль

Зарегистрирован: 02 янв 2014, 13:32
Сообщения: 81
strabbo писал(а):
Yacudzer писал(а):
Lomax писал(а):
я бы порекомендовал сделать ip unnumbered отличный от tunnel source , c обоих сторон.

Это не имеет значения. Проверено, делали уже. Соседство с кваггой поднимается только при наличии единой сети на интерфейсах gre. А хотелось бы использовать unnumbered, что бы в последствии использовать virtual-template.

Я поэтому и спрашивал, должно ли так работать, потому что всегда рукуводствовался этими правилами, которые в оффициальных книгах от циски, может в книгах они пишут одно, а реализуют по другому.
Это из одной из книг, где говорится, что соседи должны быть в одной сети


Может, у вас устаревшая инфа. Вот рабочий пример построенный на GNS:

Роутер1:
Код:
interface Loopback0
 ip address 192.168.255.128 255.255.255.255
 ip ospf network point-to-point

interface Virtual-Template2 type tunnel
 ip unnumbered Loopback0
 ip mtu 1400
 ip ospf mtu-ignore
 tunnel source FastEthernet0/0
 tunnel mode ipsec ipv4
 tunnel protection ipsec profile OFFICE-pr

router ospf 1
 redistribute static metric-type 1 subnets route-map APN-rm
 network 192.168.0.0 0.0.255.255 area 0



Роутер2:
Код:
interface Loopback0
 ip address 192.168.255.129 255.255.255.255
 ip ospf network point-to-point

interface Tunnel2
 ip unnumbered Loopback0
 ip mtu 1400
 ip ospf mtu-ignore
 tunnel source FastEthernet0/0
 tunnel destination aa.bb.cc.dd
 tunnel mode ipsec ipv4
 tunnel protection ipsec profile OFFICE-pr

router ospf 1
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0


таблица маршрутизации роутера1:
Код:
ESKO-MAIN-gw#sh ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is aa.bb.cc.dd to network 0.0.0.0

      192.168.0.0/25 is subnetted, 1 subnets
O        192.168.0.128
           [110/1010] via 192.168.255.129, 00:05:03, Virtual-Access1
      192.168.255.0/32 is subnetted, 2 subnets
O        192.168.255.129
           [110/1001] via 192.168.255.129, 00:05:03, Virtual-Access1



тоже с роутера2:
Код:
VYMPEL-gw#sh ip route ospf
     192.168.255.0/32 is subnetted, 2 subnets
O       192.168.255.128 [110/11112] via 192.168.255.128, 00:04:04, Tunnel2
O    192.168.1.0/24 [110/11112] via 192.168.255.128, 00:04:04, Tunnel2


10 май 2018, 17:16
Профиль Отправить email

Зарегистрирован: 21 май 2017, 20:13
Сообщения: 25
Инфа не старая, это вырезано из книги CCNAv3, которая вышла год назад. Хотя я покапался в RFC и нашел, что ваш вариант конфига имеет право на жизнь :). Так что скорее вмего проблема на стороне квагги, пробовали прописать статический маршрут на айпи оспф соседа на квагге? хз, может поможет ))

P.S
https://tools.ietf.org/html/rfc2328#section-7
вот RFC, на 63 странице говорится, что ваш вариант как раз можно использовать на p2p линках


10 май 2018, 17:45
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 10 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 21


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB