Сообщения без ответов | Активные темы Текущее время: 22 июн 2018, 22:03



Ответить на тему  [ Сообщений: 7 ] 
Линк между одним ISR и двумя Nexus 5k в vPC 
Автор Сообщение

Зарегистрирован: 08 окт 2016, 12:31
Сообщения: 40
Нужно подключить два Nesxus 5k в vPC домене к одному ISR G3 (4331), как это лучше сделать?
Пока на ум приходит только два варианта:

Вариант #1

ISR:

Код:
interface port-channel1
description to VPC N5K
ip address 10.10.10.1 255.255.255.248
ip nat inside

interface GigabitEthernet0/0/1
description to Nexus Switch 1
switchport mode trunk
channel-group 1

interface GigabitEthernet0/0/2
description to Nexus Switch 2
switchport mode trunk
channel-group 1


Nexus Switch 1:
Код:
!
interface vlan 10
description to ISR
ip address 10.10.10.2 255.255.255.248
!
interface port-channel1
description to ISR
switchport mode access
switchport access vlan 10
spanning-tree port type network

!
interface Ethernet1/1
switchport mode trunk
channel-group 1 mode on
!
ip route 0.0.0.0 0.0.0.0 10.10.10.1


Nexus Switch 2:
Код:
!
interface vlan 10
description to ISR
ip address 10.10.10.3 255.255.255.248
!
interface port-channel1
description to ISR
switchport mode access
switchport access vlan 10
spanning-tree port type network

!
interface Ethernet1/1
switchport mode trunk
channel-group 1 mode on
!
ip route 0.0.0.0 0.0.0.0 10.10.10.1



Вариант #2

ISR:
Код:
!
interface vlan 10
description to ISR
ip address 10.10.10.1 255.255.255.248
ip nat inside
!

interface GigabitEthernet0/0/1
description to Nexus Switch 1
switchport mode access
switchport access vlan 10

interface GigabitEthernet0/0/2
description to Nexus Switch 2
switchport mode access
switchport access vlan 10


Nexus Switch 1:
Код:
!
interface vlan 10
description to ISR
ip address 10.10.10.2 255.255.255.248
!
interface Ethernet1/1
switchport mode access
switchport access vlan 10
!
ip route 0.0.0.0 0.0.0.0 10.10.10.1



Nexus Switch 2:
Код:
!
interface vlan 10
description to ISR
ip address 10.10.10.3 255.255.255.248
!
interface Ethernet1/1
switchport mode access
switchport access vlan 10

ip route 0.0.0.0 0.0.0.0 10.10.10.1


Может кто уже делал подобное? Как лучше сделать?


09 июн 2018, 11:51
Профиль Отправить email

Зарегистрирован: 14 май 2009, 12:57
Сообщения: 1881
Откуда: Волгоград
.


09 июн 2018, 14:13
Профиль ICQ

Зарегистрирован: 09 сен 2017, 11:15
Сообщения: 51
Откуда: Default City
Самое верное решение:
Прокидываете выделенные L3 линки между ISR и каждым из нексусов + L3 пиринг между самими нексусами.

Как 2-ой по приоритету можно попробовать Ваш вариант №1, но
- убрать stp type network с нексусов
- po1 добавить в vpc, убедиться что vlan 10 разрешена на peer-link

 Все описано в vpc bp guide

https://www.cisco.com/en/US/docs/switch ... #wp1003537

_________________
@k@ fantik


09 июн 2018, 14:37
Профиль Отправить email

Зарегистрирован: 13 фев 2012, 15:46
Сообщения: 265
На этих ISR-ах, кстати, есть поддержка LACP, если что.


09 июн 2018, 16:27
Профиль

Зарегистрирован: 08 окт 2016, 12:31
Сообщения: 40
Цитата:
CiscoGuy писал(а):
Самое верное решение:
Прокидываете выделенные L3 линки между ISR и каждым из нексусов + L3 пиринг между самими нексусами.

А можно немного подробнее? Просто на каждом Nexus прописать ip прямо на L3 интерфейсе? Например так:
Код:
Nexus sw1:
interface Ethernet1
ip address 10.10.10.2 255.255.255.248

Nexus sw2:
interface Ethernet1
ip address 10.10.10.3 255.255.255.248

ISR:

Interface GigabitEthernet 0/1/1
switchport mode access
switchport access vlan 10

Interface GigabitEthernet 0/1/2
switchport mode access
switchport access vlan 10

interface Vlan10
ip address 10.10.10.1 255.255.255.248
ip nat inside
 
ip route 10.10.10.0 255.255.255.248 10.10.10.2
ip route 10.10.10.0 255.255.255.248 10.10.10.2 20


Или я не правильно понял?


09 июн 2018, 16:35
Профиль Отправить email

Зарегистрирован: 08 окт 2016, 12:31
Сообщения: 40
Fedeor писал(а):
На этих ISR-ах, кстати, есть поддержка LACP, если что.

Да, есть, но роутер один всего, так что смысла в этом мне кажется мало.


09 июн 2018, 16:36
Профиль Отправить email

Зарегистрирован: 09 сен 2017, 11:15
Сообщения: 51
Откуда: Default City
Цитата:
А можно немного подробнее? Просто на каждом Nexus прописать ip прямо на L3 интерфейсе?

Выделяете на нексусах отдельные линки под L3. Получаете топологию:

R1 -[L3]-- N1 -[L3]-- N2 --[L3]-- R2

_________________
@k@ fantik


18 июн 2018, 19:04
Профиль Отправить email
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 7 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: Google Adsense [Bot], Google [Bot] и гости: 20


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB