Сообщения без ответов | Активные темы Текущее время: 22 июн 2018, 22:03



Ответить на тему  [ Сообщений: 7 ] 
Прошу помощи с IP SLA 
Автор Сообщение

Зарегистрирован: 17 июн 2009, 09:57
Сообщения: 69
Есть два ISP оператора. Развернуть BGP возможности нет. Пулы на /28 не дают, а /24 очень дорого. Засим пытаюсь выкрутиться с ip sla.

Макет на базе 1811, c181x-adventerprisek9-mz.124-15.T17

Текущая конфигурация


track 10 rtr 1 reachability
delay down 20 up 30
!
interface FastEthernet0
description TN
ip address ISP_TN.174 255.255.255.252
ip access-group TN in
ip access-group TN out
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet1
description CN
ip address ISP_CN.210 255.255.255.252
ip access-group CN in
ip access-group CN out
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet2
switchport mode trunk
!
interface FastEthernet3
shutdown
!
interface FastEthernet4
shutdown
!
interface FastEthernet5
shutdown
!
interface FastEthernet6
shutdown
!
interface FastEthernet7
shutdown
!
interface FastEthernet8
shutdown
!
interface FastEthernet9
shutdown
!
interface Vlan1
ip address 172.16.0.1 255.255.0.0
ip nat inside
ip virtual-reassembly
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 ISP_TN.173 track 10
ip route 0.0.0.0 0.0.0.0 ISP_CN.209 4
!
ip nat inside source route-map c-n interface FastEthernet1 overload
ip nat inside source route-map t-n interface FastEthernet0 overload
!
ip access-list extended CN
permit ip any any
ip access-list extended TN
permit ip any any
ip access-list extended c-n
permit ip 172.16.0.0 0.0.255.255 any
ip access-list extended nat
permit ip 172.16.0.0 0.0.255.255 any
ip access-list extended t-n
permit ip 172.16.0.0 0.0.255.255 any
!
ip sla 1
icmp-echo 8.8.8.8 source-interface FastEthernet0
timeout 1000
threshold 40
frequency 3
ip sla schedule 1 life forever start-time now
!
route-map t-n permit 10
match ip address t-n
match interface FastEthernet0
!
route-map c-n permit 10
match ip address c-n
match interface FastEthernet1


Подключено всё к 2960 (c2960-lanbasek9-mz.122-58), который эмулирует WAN. Тут проблем нет, так как DFL-260E балансировку делает без замечаний.

interface Port-channel1
description LACP_2_VMware
switchport mode trunk
!
interface FastEthernet0/1
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 200
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/3
switchport access vlan 300
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/4
switchport access vlan 201
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/5
switchport access vlan 301
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/6
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/7
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet0/8
switchport mode trunk
channel-group 1 mode on
!
interface GigabitEthernet0/1
!
interface Vlan1
ip address 172.16.3.100 255.255.0.0
!
interface Vlan200
ip address ISP_TN.173 255.255.255.252
ip access-group VL200 in
!
interface Vlan201
ip address ISP_CN.209 255.255.255.252
ip access-group VL201 in
!
interface Vlan300
ip address RM_ISP_1.213 255.255.255.252
!
interface Vlan301
ip address RM_ISP_2.177 255.255.255.248
!
interface Vlan555
ip address 8.8.8.8 255.255.255.0
!
interface Vlan777
ip address 8.8.4.4 255.255.255.0
!
ip access-list extended VL200
deny ip host ISP_TN.174 host 8.8.4.4
permit ip any any
ip access-list extended VL201
deny ip host ISP_CN.210 host 8.8.8.8
permit ip any any


GATE#sh ip route
Gateway of last resort is ISP_TN.173 to network 0.0.0.0

ISP_CN.0/30 is subnetted, 1 subnets
C ISP_CN.208 is directly connected, FastEthernet1
C 172.16.0.0/16 is directly connected, Vlan1
ISP_TN.0/30 is subnetted, 1 subnets
C ISP_TN.172 is directly connected, FastEthernet0
S* 0.0.0.0/0 [1/0] via ISP_TN.173


GATE#SH IP ACCE
Extended IP access list CN
10 permit ip any any (5668 matches)
Extended IP access list TN
10 permit ip any any (6406 matches)
Extended IP access list c-n
10 permit ip 172.16.0.0 0.0.255.255 any
Extended IP access list nat
10 permit ip 172.16.0.0 0.0.255.255 any
Extended IP access list t-n
10 permit ip 172.16.0.0 0.0.255.255 any


Маршрут вроде бы уходит корректно, на основного оператора. Но! Стоит выдернуть шнурок резервного CN и всё падает. Пакеты в мир не уходят.

Помогите решить вопрос. Буду искренне признателен.


14 июн 2018, 11:53
Профиль

Зарегистрирован: 17 июн 2009, 09:57
Сообщения: 69
После перезагрузки маршрутизатора, при физически отключенном резервном канале, проскакивает пять пакетов по основному интерфейсу. Потом трафик останавливается. Но стоит воткнуться резервным шнурком и всё сразу же работает.

При всём при этом, стоит выдернуть шнурок основного оператора и трафик на 8.8.8.8 перестаёт идти, так как на коммутаторе ему запрещено проходить с резервного канала.

После того как вкинул шнурок основного оператора маршрут на сеть не восстанавливается. Но стоит передёрнуть шнурок резервного оператора - трафик чудесным образом пошёл по обоим каналам.


14 июн 2018, 12:56
Профиль

Зарегистрирован: 10 окт 2012, 09:51
Сообщения: 2522
прописать статический маршрут к 8.8.8.8?


14 июн 2018, 13:21
Профиль

Зарегистрирован: 17 июн 2009, 09:57
Сообщения: 69
Всё. Победил. Работает. :o

Время переключения между операторами четыре пинга :)


14 июн 2018, 13:31
Профиль

Зарегистрирован: 10 окт 2012, 09:51
Сообщения: 2522
и?


14 июн 2018, 13:32
Профиль

Зарегистрирован: 17 июн 2009, 09:57
Сообщения: 69
track 10 rtr 1 reachability
!
track 20 rtr 2 reachability
!
track 50 list boolean or
object 10
object 20
delay down 10 up 5

ip route 0.0.0.0 0.0.0.0 GW_ISP1 10 track 50
ip route 0.0.0.0 0.0.0.0 GW_ISP2 20
!
ip nat translation timeout 120
ip nat translation tcp-timeout 3600
ip nat translation udp-timeout 120
ip nat translation finrst-timeout 10
ip nat translation syn-timeout 30
ip nat translation dns-timeout 30
ip nat inside source route-map cit-net interface FastEthernet1 overload
ip nat inside source route-map top-net interface FastEthernet0 overload

ip access-list extended nat
permit ip 172.16.0.0 0.0.255.255 any
!
ip sla 1
icmp-echo 8.8.8.8 source-interface FastEthernet0
timeout 1500
threshold 1000
frequency 3
ip sla schedule 1 life forever start-time now
ip sla 2
icmp-echo GW_ISP1 source-interface FastEthernet0
timeout 1500
threshold 1000
frequency 3
ip sla schedule 2 life forever start-time now

route-map t-n permit 10
match ip address nat
match interface FastEthernet0
!
route-map c-n permit 20
match ip address nat
match interface FastEthernet1

event manager applet t-n_UP
event track 50 state up
action 001 cli command "enable"
action 002 cli command "clear ip nat translation *"
action 003 syslog msg "t-n is UP"
event manager applet t-n_DOWN
event track 50 state down
action 001 cli command "enable"
action 002 cli command "clear ip nat translation *"
action 003 syslog msg "t-n is DOWN"


14 июн 2018, 14:01
Профиль

Зарегистрирован: 17 июн 2009, 09:57
Сообщения: 69
ответ нашёл тут http://www.maxblogs.ru/articles/rezervi ... ov-v-cisco


14 июн 2018, 14:02
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 7 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: Google Adsense [Bot], Google [Bot] и гости: 20


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB