Сообщения без ответов | Активные темы Текущее время: 23 май 2019, 12:46



Ответить на тему  [ Сообщений: 2 ] 
Подключение CIsco 881 к провайдеру по PPTP 
Автор Сообщение

Зарегистрирован: 03 мар 2019, 11:25
Сообщения: 33
1. Что-то не выходит у меня заставить CIsco 881 подключиться к провайдеру по PPTP.
2. Бытовой роутер и Windows 2012 R2 server - подключаются успешно. А вот циска не желает.
3. Может кто ткнет пальцем в дефект? Текущая конфигурация и дебаг-лог прилагаются

Код:
cisco.k259#show run
Building configuration...

Current configuration : 7022 bytes
!
! Last configuration change at 11:10:30 GMT Fri Mar 8 2019 by atest
! NVRAM config last updated at 18:11:25 GMT Sun Mar 3 2019 by atest
!
version 15.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname cisco.k259
!
boot-start-marker
boot-end-marker
!
!
logging discriminator FAN-FAIL severity drops 3 facility drops FAN mnemonics drops FAN_FAILED
logging buffered discriminator FAN-FAIL
no logging console
logging monitor discriminator FAN-FAIL
enable secret 5 $1$WSti$mDMsh6sXY2iguEI/Mchiy1
enable password XXXXXX_
!
no aaa new-model
memory-size iomem 10
clock timezone GMT 5 0
!
crypto pki trustpoint TP-self-signed-3690135629
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3690135629
 revocation-check none
 rsakeypair TP-self-signed-3690135629
!
!
crypto pki certificate chain TP-self-signed-3690135629
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33363930 31333536 3239301E 170D3139 30323133 30333135
  34395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 36393031
  33353632 3930819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100B94F 2E9D45ED BDD6ADA6 715ACF2E ADC0E168 31166C57 15631125 0B66B1A5
  752DDDA5 14704956 1B39880D A34FD2B0 C4DA4EB2 439F71D1 F53878ED 1A77BC31
  C61CBAF7 A381DC9C D0BC9242 A48C41F0 1BC18635 036FCEDA 8A31FD58 765D9410
  305F5468 68960B0B 4963DF0B 35CADA5D 86F220CE F4974A3A FB9A6759 0B3E9E6E
  37FB0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 141619A0 9ED55215 E39DB668 8F348DCA C104A706 99301D06
  03551D0E 04160414 1619A09E D55215E3 9DB6688F 348DCAC1 04A70699 300D0609
  2A864886 F70D0101 05050003 81810058 04F60F24 86EE15BC FBFAB463 5430CB2E
  9B150A52 879E1508 3E023C49 47FF16B9 8ABAC325 6DCCC760 AEE95943 3F72CCD8
  A1D135B2 923A3813 E75154B7 C13A3AAC 4260A0CA FFAF64FC 37F556E2 AC7658A3
  65F80B41 BC6AFDC6 9BB98F72 DB818294 3BA601D5 496050E4 C9425AD9 3757208A
  668A5BB2 4FEE45AC 3AE58B3C 4A4F5B
        quit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address 192.168.0.1 192.168.0.7
!
ip dhcp pool k259
 import all
 network 192.168.0.0 255.255.255.0
 default-router 192.168.0.1
 domain-name k259
 dns-server 192.168.0.12 8.8.8.8
 lease 0 2
!
!
!
ip domain name k259
ip name-server 192.168.0.12
ip inspect WAAS flush-timeout 10
ip cef
no ipv6 cef
!
!
vpdn enable
!
vpdn-group PPTP_CLIENT
 description Rostelecom ISP
 request-dialin
  protocol pptp
  pool-member 1
 initiate-to ip 10.0.0.1
!
cts logging verbose
license udi pid CISCO881W-GN-E-K9 sn FCZ164190LZ
!
!
username atest privilege 15 secret 4 6in4Lru2ZZ8N8cUij4vPlkL..hsURCkjm.d4NOR2
!
!
!
!
no cdp run
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface FastEthernet4
 ip address 10.0.47.132 255.255.255.0
 duplex auto
 speed auto
!
interface wlan-ap0
 description Service module interface to manage the embedded AP
 ip address 10.10.11.1 255.255.255.0
 arp timeout 0
!
interface Wlan-GigabitEthernet0
 description Internal switch interface connecting to the embedded AP
 no ip address
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 ip tcp adjust-mss 1452
!
interface Dialer0
 description Rostelecom ISP
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 shutdown
 dialer pool 1
 dialer idle-timeout 0
 dialer string 123
 dialer persistent
 dialer vpdn
 ppp authentication ms-chap-v2
 ppp chap hostname 90.157.26.245
 ppp chap password 0 XXXXXXXXX
 no cdp enable
!
ip forward-protocol nd
ip http server
ip http access-class 23
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip http path flash:
!
no ip ftp passive
ip dns server
ip nat inside source list 1 interface Dialer0 overload
ip route 10.0.0.1 255.255.255.255 10.0.47.1
!
dialer-list 1 protocol ip permit
!
snmp-server community k259 RO
access-list 1 remark internet
access-list 1 remark CCP_ACL Category=2
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 1 permit 10.10.10.0 0.0.0.255
access-list 23 remark CCP_ACL Category=17
access-list 23 permit 10.10.10.0 0.0.0.7
access-list 23 permit 192.168.0.0 0.0.0.15
!
 vstack
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device
-----------------------------------------------------------------------
^C
banner login ^C
-----------------------------------------------------------------------
Cisco Configuration Professional (Cisco CP) is installed on this device.
-----------------------------------------------------------------------
^C
!
line con 0
 login local
 no modem enable
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
line vty 0 4
 access-class 23 in
 privilege level 15
 password XXXXXX
 login local
 transport input telnet ssh
!
ntp master
ntp update-calendar
ntp server ntp2.stratum2.ru
!
end



Код:
cisco.k259#show debug
PPP:
  PPP detailed event debugging is on
  PPP authentication debugging is on
  PPP authorization debugging is on
  MPPE Packet Details debugging is on
  PPP protocol errors debugging is on
  PPP protocol negotiation debugging is on
  PPP SSS events debugging is on
  PPP Callback Control Protocol debugging is on
  PPP Negotiation Elogs debugging is on
  PPP Detailed Elogs debugging is on
VPN:
  L2TP/PPTP protocol events debugging is on
  L2TP/PPTP protocol errors debugging is on
  VPDN errors debugging is on
  VPDN group select details debugging is on

Debug output - этот фрагмент оно крутит бесконечно

Код:
Mar  8 06:03:28.183: %DIALER-6-BIND: Interface Vi1 bound to profile Di0
Mar  8 06:03:28.183: Vi1 PPP: Sending cstate UP notification
Mar  8 06:03:28.183: Vi1 PPP: Missed a Link-Up transition, starting PPP
Mar  8 06:03:28.183: Vi1 PPP: Buffering PPP packet
Mar  8 06:03:28.183: Vi1 PPP: Processing CstateUp message
Mar  8 06:03:28.183: Vi1 PPP: Change SIP state from Down to SSS Setup
Mar  8 06:03:28.183: Vi1 PPP: old[Down] event[CstateUp] state[SSS Setup]
Mar  8 06:03:28.183: Vi1 PPP: Processing FastStart message
Mar  8 06:03:28.183: Vi1 ***BAD Serial EVENT***
Mar  8 06:03:28.183:       last event[FastStart] last state[Down] state[SSS Setup]
Mar  8 06:03:28.183: Vi1 PPP: old[SSS Setup] event[FastStart] state[SSS Setup]
Mar  8 06:03:28.187: Vi1 PPP SIP segment: Provisioned
Mar  8 06:03:28.187: Vi1 PPP SIP segment:     if_number     13
Mar  8 06:03:28.187: Vi1 PPP SIP segment:     sub_if_number 13
Mar  8 06:03:28.187: Vi1 PPP SIP segment:     ppp_vencap    0
Mar  8 06:03:28.187: Vi1 PPP SIP segment:     access id     52000025
Mar  8 06:03:28.187: Vi1 PPP SIP segment:     switch hdl    0
Mar  8 06:03:28.187: Vi1 PPP SIP segment:     sss circuit   0
Mar  8 06:03:28.187: Vi1 PPP SIP segment:     lcp magic     0
Mar  8 06:03:28.187: Vi1 PPP SIP segment:     local term    0
Mar  8 06:03:28.187: Vi1 PPP SIP segment:     lcp up        0
Mar  8 06:03:28.187: Vi1 PPP SIP segment:     punt to RP    0
Mar  8 06:03:28.187: Vi1 PPP SIP segment:     cond debug    1
Mar  8 06:03:28.187: Vi1 PPP SIP segment:     vp_bound      0
Mar  8 06:03:28.187: Vi1 PPP SIP segment:     fwded         0
Mar  8 06:03:28.187: Vi1 PPP: Received SSS-Mgr Need-More-Keys from SSS
Mar  8 06:03:28.187: Vi1 PPP: Change SIP state from SSS Setup to Binding
Mar  8 06:03:28.187: Vi1 PPP: old[SSS Setup] event[MoreKeys] state[Binding]
Mar  8 06:03:28.187: PPP: Alloc Context [88532874]
Mar  8 06:03:28.187: ppp37 PPP: Initialized Context 88532874
Mar  8 06:03:28.187: ppp37 PPP: Phase is ESTABLISHING
Mar  8 06:03:28.187: ppp37 PPP: Using AAA Unique Id = 5B
Mar  8 06:03:28.187: PPP: Bind ppp37 to Virtual-Access1
Mar  8 06:03:28.187: Vi1 PPP: Static Bind peer_type[0]
Mar  8 06:03:28.187: Vi1 PPP: Send Message[Static Bind Response]
Mar  8 06:03:28.187: Vi1 PPP: Authorization required
Mar  8 06:03:28.187: Vi1 PPP: Using dialer call direction
Mar  8 06:03:28.187: Vi1 PPP: Treating connection as a callout
Mar  8 06:03:28.187: Vi1 PPP: Session handle[C7000025] Session id[37]
Mar  8 06:03:28.191: Vi1 PPP LCP: negotiation authorized = 1, tacacs author = 0
Mar  8 06:03:28.191: Vi1 LCP: Event[OPEN] State[Initial to Starting]
Mar  8 06:03:28.191: Vi1 PPP LCP: neg is authorized, processing CP UP event
Mar  8 06:03:28.191: Vi1 LCP: O CONFREQ [Starting] id 1 len 15
Mar  8 06:03:28.191: Vi1 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Mar  8 06:03:28.191: Vi1 LCP:    MagicNumber 0xDF0EC1BE (0x0506DF0EC1BE)
Mar  8 06:03:28.191: Vi1 LCP: Event[UP] State[Starting to REQsent]
Mar  8 06:03:28.191: Vi1 PPP: Received Static Bind Response from PPP
Mar  8 06:03:28.191: Vi1 PPP: Redirecting buffered packet
Mar  8 06:03:28.191: Vi1 PPP: Change SIP state from Binding to Up
Mar  8 06:03:28.191: Vi1 PPP: old[Binding] event[PPPBindResp] state[Up]
Mar  8 06:03:28.191: Vi1 LCP: I CONFREQ [REQsent] id 1 len 19
Mar  8 06:03:28.191: Vi1 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Mar  8 06:03:28.191: Vi1 LCP:    MRU 1436 (0x0104059C)
Mar  8 06:03:28.191: Vi1 LCP:    MagicNumber 0x7271C6B9 (0x05067271C6B9)
Mar  8 06:03:28.191: Vi1 PPP LCP: neg is authorized, processing incoming CONFREQ
Mar  8 06:03:28.191: Vi1 LCP: O CONFNAK [REQsent] id 1 len 8
Mar  8 06:03:28.191: Vi1 LCP:    MRU 1500 (0x010405DC)
Mar  8 06:03:28.191: Vi1 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]
Mar  8 06:03:28.191: Vi1 LCP: I CONFACK [REQsent] id 1 len 15
Mar  8 06:03:28.191: Vi1 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Mar  8 06:03:28.191: Vi1 LCP:    MagicNumber 0xDF0EC1BE (0x0506DF0EC1BE)
Mar  8 06:03:28.191: Vi1 LCP: Event[Receive ConfAck] State[REQsent to ACKrcvd]
Mar  8 06:03:28.195: Vi1 LCP: I CONFREQ [ACKrcvd] id 2 len 15
Mar  8 06:03:28.195: Vi1 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Mar  8 06:03:28.195: Vi1 LCP:    MagicNumber 0x7271C6B9 (0x05067271C6B9)
Mar  8 06:03:28.195: Vi1 PPP LCP: neg is authorized, processing incoming CONFREQ
Mar  8 06:03:28.195: Vi1 LCP: O CONFACK [ACKrcvd] id 2 len 15
Mar  8 06:03:28.195: Vi1 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Mar  8 06:03:28.195: Vi1 LCP:    MagicNumber 0x7271C6B9 (0x05067271C6B9)
Mar  8 06:03:28.195: Vi1 LCP: Event[Receive ConfReq+] State[ACKrcvd to Open]
Mar  8 06:03:28.195: Vi1 PPP: Queue CHAP code[1] id[1]
Mar  8 06:03:28.207: Vi1 PPP: Phase is AUTHENTICATING, by both
Mar  8 06:03:28.207: Vi1 MS-CHAP-V2: O CHALLENGE id 1 len 34 from "90.157.26.245"
Mar  8 06:03:28.207: Vi1 CHAP: Redirect packet to Vi1
Mar  8 06:03:28.207: Vi1 MS-CHAP-V2: I CHALLENGE id 1 len 21
Mar  8 06:03:28.207: Vi1 MS CHAP V2: No name received from peer
Mar  8 06:03:28.211: Vi1 MS CHAP V2: Using hostname from interface CHAP
Mar  8 06:03:28.211: Vi1 MS CHAP V2: Using password from interface CHAP
Mar  8 06:03:28.211: Vi1 MS-CHAP-V2: O RESPONSE id 1 len 67 from "90.157.26.245"
Mar  8 06:03:28.211: Vi1 LCP: State is Open
Mar  8 06:03:28.267: Vi1 MS-CHAP-V2: I SUCCESS id 1 len 73 msg is "S=528B7F7ACF1C23D06BE3387CA684B28A6CD6E00F M=Authentication succeeded"
Mar  8 06:03:28.267: Vi1 MS CHAP V2 No Password found for :
Mar  8 06:03:28.267: Vi1 MS CHAP V2 Check AuthenticatorResponse Success for : 90.157.26.245
Mar  8 06:03:28.267: Vi1 PPP: Queue IPCP code[1] id[1]
Mar  8 06:03:29.167: %LINEPROTO-5-UPDOWN: Line protocol on Interface Dialer0, changed state to up
Mar  8 06:03:31.267: Vi1 PPP: Update queued IPCP code[1] id[1]terminal monitor~
Mar  8 06:03:34.267: Vi1 PPP: Update queued IPCP code[1] id[1]
Mar  8 06:03:37.267: Vi1 PPP: Update queued IPCP code[1] id[1]
Mar  8 06:03:38.223: Vi1 AUTH: Timeout 1
Mar  8 06:03:38.223: Vi1 MS-CHAP-V2: O CHALLENGE id 2 len 34 from "90.157.26.245"
Mar  8 06:03:40.267: Vi1 PPP: Update queued IPCP code[1] id[1]
Mar  8 06:03:43.267: Vi1 PPP: Update queued IPCP code[1] id[1]
Mar  8 06:03:46.267: Vi1 PPP: Update queued IPCP code[1] id[1]
Mar  8 06:03:48.239: Vi1 AUTH: Timeout 2
Mar  8 06:03:48.239: Vi1 MS-CHAP-V2: O CHALLENGE id 3 len 34 from "90.157.26.245"
Mar  8 06:03:49.267: Vi1 PPP: Update queued IPCP code[1] id[1]
Mar  8 06:03:52.267: Vi1 PPP: Update queued IPCP code[1] id[1]
Mar  8 06:03:55.267: Vi1 PPP: Update queued IPCP code[1] id[1]
Mar  8 06:03:58.255: Vi1 AUTH: Timeout 3
Mar  8 06:03:58.255: Vi1 MS-CHAP-V2: O CHALLENGE id 4 len 34 from "90.157.26.245"
Mar  8 06:03:58.267: Vi1 LCP: I TERMREQ [Open] id 5 len 4
Mar  8 06:03:58.267: Vi1 PPP DISC: Received LCP TERMREQ from peer
Mar  8 06:03:58.267: PPP: NET STOP send to AAA.
Mar  8 06:03:58.267: Vi1 PPP: Phase is TERMINATING
Mar  8 06:03:58.267: Vi1 LCP: O TERMACK [Open] id 5 len 4
Mar  8 06:03:58.267: Vi1 LCP: Event[Receive TermReq] State[Open to Stopping]
Mar  8 06:03:58.267: PPTP tnl   018FD:________: CC I msg 13 for unknown session
Mar  8 06:03:58.467: PPTP tnl   018FD:________: StopCCRQ -> state change estabd to idle
Mar  8 06:03:58.467: PPTP tnl   018FD:________: Shutting down tunnel
Mar  8 06:03:58.471: L2TUN APP: handle/6393Free switch hdl 6395
Mar  8 06:03:58.471: L2TUN APP: handle/6393shutdown app session
Mar  8 06:03:58.471: PPTP _____:018FD:________: close -> state change estabd to wt-cdn
Mar  8 06:03:58.471: Vi1 PPP: Sending cstate DOWN notification
Mar  8 06:03:58.471: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di0
Mar  8 06:03:58.471: Vi1 PPP: Block vaccess from being freed [0x10]
Mar  8 06:03:58.475: Vi1 PPP: Processing CstateDown message
Mar  8 06:03:58.475: Vi1 PPP: Received graceful disconnect from SIP
Mar  8 06:03:58.475: Vi1 LCP: Event[CLOSE] State[Stopping to Closing]
Mar  8 06:03:58.475: Vi1 PPP: ppp_sip_switching_cleanup
Mar  8 06:03:58.475: Vi1 PPP: Change SIP state from Init to Down
Mar  8 06:03:58.475: Vi1 PPP: old[Up] event[CstateDown] state[Down]
Mar  8 06:03:58.475: Vi1 LCP: Event[DOWN] State[Closing to Initial]
Mar  8 06:03:58.475: Vi1 PPP: Clearing AAA Unique Id = 5B
Mar  8 06:03:58.475: Vi1 PPP: Unlocked by [0x10] Still Locked by [0x0]
Mar  8 06:03:58.475: Vi1 PPP: Free previously blocked vaccess
Mar  8 06:03:58.475: PPTP:(Tnl0:Sn43450)Vi1 Block vaccess from being freed.
Mar  8 06:03:58.475: Vi1 PPP: Phase is DOWN
Mar  8 06:03:58.479: PPTP       _____:________: Event tcp-disc was illegal in old state
Mar  8 06:03:58.479: Vi1 PPP SIP segment: Unprovision
Mar  8 06:03:58.479: Vi1 PPP SIP segment: CLEANUP
Mar  8 06:03:59.471: Vi2 PPP: Change SIP state from Init to Down
Mar  8 06:03:59.471: Vi2 PPP: old[Init] event[Encap] state[Down]
Mar  8 06:03:59.471: Vi2 PPP: ppp_sip_switching_cleanup
Mar  8 06:03:59.471: Vi2 PPP: Change SIP state from Init to Down
Mar  8 06:03:59.471: Vi2 PPP: old[Down] event[Encap] state[Down]
L2X_ADJ: Vi2:midchain adj repopulate, nothing to do
Mar  8 06:03:59.471: L2TUN APP: handle/6401Peer AIE:00000000 Peer-peer 00000000 Ours 00000000
Mar  8 06:03:59.471: L2TUN APP: handle/6401New peer; get switch hdl 0
Mar  8 06:03:59.471: L2TUN APP: handle/6401Allocate switch hdl 10499
Mar  8 06:03:59.475: L2X        _____:________: DB: adding cc with id 37221 (total 2)
Mar  8 06:03:59.475: L2X        _____:________: DB: added cc with id 37221 (total 3)
Mar  8 06:03:59.475: PPTP tnl   02905:________: Tunnel created; we initiated
Mar  8 06:03:59.475: L2X        _____:________: DB: added session (cc id 37221, sess id 23207) (total 1)
Mar  8 06:03:59.475: L2X        _____:________: DB: added session id 23207 into flat id space (total 2)
Mar  8 06:03:59.475: L2X        _____:________: l2x_open_socket: is called
Mar  8 06:03:59.475: PPTP tnl   02905:________: new-sess -> state change idle to wt-cnnct
Mar  8 06:03:59.475: PPTP tnl   02905:________: TCP active opening to 10.0.0.1
Mar  8 06:03:59.475: L2X        _____:________: l2x_open_socket: is called
Mar  8 06:03:59.475: PPTP tnl   02905:________: tcp-conn -> state change wt-cnnct to wt-sccrp
Mar  8 06:03:59.479: PPTP       _____:________: L2X DB: no id
Mar  8 06:03:59.479: PPTP tnl   02905:________: I SCCRP from local
Mar  8 06:03:59.479: PPTP tnl   02905:________: protocol version 100
Mar  8 06:03:59.479: PPTP tnl   02905:________: result code 1
Mar  8 06:03:59.479: PPTP tnl   02905:________: error code 0
Mar  8 06:03:59.479: PPTP tnl   02905:________: framing caps 3
Mar  8 06:03:59.479: PPTP tnl   02905:________: bearer caps 3
Mar  8 06:03:59.479: PPTP tnl   02905:________: max channels 1
Mar  8 06:03:59.479: PPTP tnl   02905:________: firmware rev 1
Mar  8 06:03:59.479: PPTP tnl   02905:________: hostname "local"
Mar  8 06:03:59.479: PPTP tnl   02905:________: vendor "cananian"
Mar  8 06:03:59.479: PPTP tnl   02905:________: SCCRP-ok -> state change wt-sccrp to estabd
Mar  8 06:03:59.479: PPTP _____:02905:________: tnl-up -> state change wt-tun to wt-ocrp
Mar  8 06:03:59.483: PPTP _____:02905:________: OCRP-ok -> state change wt-ocrp to estabd
Mar  8 06:03:59.483: L2X        _____:________: DB: added session: rIP 10.0.0.1, rSession id 19338 (total 2)
Mar  8 06:03:59.483: PPTP _____:_____:________: L2X session data plane setup successful
L2X_ADJ: Vi2:allocated ctx, size 1
Mar  8 06:03:59.483: PPTP:(Tnl0:Sn23207)L2X setup idb switching
Mar  8 06:03:59.483: L2X:Session DB (Tnl/Sn: 0/23207): Stored the switching session in the session DB
Mar  8 06:03:59.483: PPTP:(Tnl0:Sn23207)L2X s/w switching session provisioned
L2X_ADJ: Vi2:midchain adj repopulate, nothing to do
Mar  8 06:03:59.487: %DIALER-6-BIND: Interface Vi2 bound to profile Di0
Mar  8 06:03:59.487: Vi2 PPP: Sending cstate UP notification
Mar  8 06:03:59.487: Vi2 PPP: Processing CstateUp message
Mar  8 06:03:59.487: Vi2 PPP: Change SIP state from Down to SSS Setup
Mar  8 06:03:59.487: Vi2 PPP: old[Down] event[CstateUp] state[SSS Setup]
Mar  8 06:03:59.487: Vi2 PPP SIP segment: Provisioned
Mar  8 06:03:59.487: Vi2 PPP SIP segment:     if_number     14
Mar  8 06:03:59.487: Vi2 PPP SIP segment:     sub_if_number 14
Mar  8 06:03:59.487: Vi2 PPP SIP segment:     ppp_vencap    0
Mar  8 06:03:59.487: Vi2 PPP SIP segment:     access id     F4000026
Mar  8 06:03:59.487: Vi2 PPP SIP segment:     switch hdl    0
Mar  8 06:03:59.487: Vi2 PPP SIP segment:     sss circuit   0
Mar  8 06:03:59.487: Vi2 PPP SIP segment:     lcp magic     0
Mar  8 06:03:59.487: Vi2 PPP SIP segment:     local term    0
Mar  8 06:03:59.487: Vi2 PPP SIP segment:     lcp up        0
Mar  8 06:03:59.487: Vi2 PPP SIP segment:     punt to RP    0
Mar  8 06:03:59.487: Vi2 PPP SIP segment:     cond debug    1
Mar  8 06:03:59.487: Vi2 PPP SIP segment:     vp_bound      0
Mar  8 06:03:59.487: Vi2 PPP SIP segment:     fwded         0
Mar  8 06:03:59.491: Vi2 PPP: Received SSS-Mgr Need-More-Keys from SSS
Mar  8 06:03:59.491: Vi2 PPP: Change SIP state from SSS Setup to Binding
Mar  8 06:03:59.491: Vi2 PPP: old[SSS Setup] event[MoreKeys] state[Binding]
Mar  8 06:03:59.491: PPP: Alloc Context [88532874]
Mar  8 06:03:59.491: ppp38 PPP: Initialized Context 88532874
Mar  8 06:03:59.491: ppp38 PPP: Phase is ESTABLISHING
Mar  8 06:03:59.491: ppp38 PPP: Using AAA Unique Id = 5C
Mar  8 06:03:59.491: PPP: Bind ppp38 to Virtual-Access2
Mar  8 06:03:59.491: Vi2 PPP: Static Bind peer_type[0]
Mar  8 06:03:59.491: Vi2 PPP: Send Message[Static Bind Response]
Mar  8 06:03:59.491: Vi2 PPP: Authorization required
Mar  8 06:03:59.491: Vi2 PPP: Using dialer call direction
Mar  8 06:03:59.491: Vi2 PPP: Treating connection as a callout
Mar  8 06:03:59.491: Vi2 PPP: Session handle[A4000026] Session id[38]
Mar  8 06:03:59.491: Vi2 PPP LCP: negotiation authorized = 1, tacacs author = 0
Mar  8 06:03:59.491: Vi2 LCP: Event[OPEN] State[Initial to Starting]
Mar  8 06:03:59.491: Vi2 PPP LCP: neg is authorized, processing CP UP event
Mar  8 06:03:59.491: Vi2 LCP: O CONFREQ [Starting] id 1 len 15
Mar  8 06:03:59.491: Vi2 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Mar  8 06:03:59.491: Vi2 LCP:    MagicNumber 0xDF0F3C1B (0x0506DF0F3C1B)
Mar  8 06:03:59.491: Vi2 LCP: Event[UP] State[Starting to REQsent]
Mar  8 06:03:59.491: Vi2 PPP: Received Static Bind Response from PPP
Mar  8 06:03:59.495: Vi2 PPP: Change SIP state from Binding to Up
Mar  8 06:03:59.495: Vi2 PPP: old[Binding] event[PPPBindResp] state[Up]
Mar  8 06:03:59.495: Vi2 LCP: I CONFACK [REQsent] id 1 len 15
Mar  8 06:03:59.495: Vi2 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Mar  8 06:03:59.495: Vi2 LCP:    MagicNumber 0xDF0F3C1B (0x0506DF0F3C1B)
Mar  8 06:03:59.495: Vi2 LCP: Event[Receive ConfAck] State[REQsent to ACKrcvd]
Mar  8 06:04:01.487: Vi2 LCP: O CONFREQ [ACKrcvd] id 2 len 15
Mar  8 06:04:01.487: Vi2 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Mar  8 06:04:01.487: Vi2 LCP:    MagicNumber 0xDF0F3C1B (0x0506DF0F3C1B)
Mar  8 06:04:01.487: Vi2 LCP: Event[Timeout+] State[ACKrcvd to REQsent]
Mar  8 06:04:01.487: Vi2 LCP: I CONFACK [REQsent] id 2 len 15
Mar  8 06:04:01.487: Vi2 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Mar  8 06:04:01.487: Vi2 LCP:    MagicNumber 0xDF0F3C1B (0x0506DF0F3C1B)
Mar  8 06:04:01.487: Vi2 LCP: Event[Receive ConfAck] State[REQsent to ACKrcvd]
Mar  8 06:04:02.479: Vi2 LCP: I CONFREQ [ACKrcvd] id 1 len 19
Mar  8 06:04:02.479: Vi2 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Mar  8 06:04:02.479: Vi2 LCP:    MRU 1436 (0x0104059C)
Mar  8 06:04:02.479: Vi2 LCP:    MagicNumber 0x16EEA61C (0x050616EEA61C)
Mar  8 06:04:02.483: Vi2 PPP LCP: neg is authorized, processing incoming CONFREQ
Mar  8 06:04:02.483: Vi2 LCP: O CONFNAK [ACKrcvd] id 1 len 8
Mar  8 06:04:02.483: Vi2 LCP:    MRU 1500 (0x010405DC)
Mar  8 06:04:02.483: Vi2 LCP: Event[Receive ConfReq-] State[ACKrcvd to ACKrcvd]
Mar  8 06:04:02.483: Vi2 LCP: I CONFREQ [ACKrcvd] id 2 len 15
Mar  8 06:04:02.483: Vi2 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Mar  8 06:04:02.483: Vi2 LCP:    MagicNumber 0x16EEA61C (0x050616EEA61C)
Mar  8 06:04:02.483: Vi2 PPP LCP: neg is authorized, processing incoming CONFREQ
Mar  8 06:04:02.483: Vi2 LCP: O CONFACK [ACKrcvd] id 2 len 15
Mar  8 06:04:02.483: Vi2 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Mar  8 06:04:02.483: Vi2 LCP:    MagicNumber 0x16EEA61C (0x050616EEA61C)
Mar  8 06:04:02.483: Vi2 LCP: Event[Receive ConfReq+] State[ACKrcvd to Open]
Mar  8 06:04:02.483: Vi2 PPP: Queue CHAP code[1] id[1]
Mar  8 06:04:02.511: Vi2 PPP: Phase is AUTHENTICATING, by both
Mar  8 06:04:02.511: Vi2 MS-CHAP-V2: O CHALLENGE id 1 len 34 from "90.157.26.245"
Mar  8 06:04:02.511: Vi2 CHAP: Redirect packet to Vi2
Mar  8 06:04:02.511: Vi2 MS-CHAP-V2: I CHALLENGE id 1 len 21
Mar  8 06:04:02.511: Vi2 MS CHAP V2: No name received from peer
Mar  8 06:04:02.515: Vi2 MS CHAP V2: Using hostname from interface CHAP
Mar  8 06:04:02.515: Vi2 MS CHAP V2: Using password from interface CHAP
Mar  8 06:04:02.515: Vi2 MS-CHAP-V2: O RESPONSE id 1 len 67 from "90.157.26.245"
Mar  8 06:04:02.515: Vi2 LCP: State is Open
Mar  8 06:04:02.519: Vi2 MS-CHAP-V2: I SUCCESS id 1 len 73 msg is "S=387A06D2AC9ABF622CC4EBB52DC6ABF64CD5B023 M=Authentication succeeded"
Mar  8 06:04:02.519: Vi2 MS CHAP V2 No Password found for :
Mar  8 06:04:02.519: Vi2 MS CHAP V2 Check AuthenticatorResponse Success for : 90.157.26.245
Mar  8 06:04:02.519: Vi2 PPP: Queue IPCP code[1] id[1]
Mar  8 06:04:05.519: Vi2 PPP: Update queued IPCP code[1] id[1]
Mar  8 06:04:08.199: PPTP _____:018FD:________: timeout -> state change wt-cdn to terminal
Mar  8 06:04:08.199: PPTP _____:018FD:________: Destroying session
Mar  8 06:04:08.199: PPTP _____:_____:________: L2X request teardown data plane
Mar  8 06:04:08.199: L2X        _____:________: DB: removed session: rIP 10.0.0.1, rSession id 19324 (total 1)
Mar  8 06:04:08.199: L2X        _____:________: DB: removed session with id 43450 (total 0)
Mar  8 06:04:08.199: L2X        _____:________: DB: removed session id 43450 (total 1)
Mar  8 06:04:08.199: PPTP tnl   018FD:________: no-sess -> state change idle to terminal
Mar  8 06:04:08.199: PPTP tnl   018FD:________: Destroy tunnel
Mar  8 06:04:08.199: PPTP       _____:________: No l2x in cc
Mar  8 06:04:08.199: L2X        _____:________: DB: removed cc with id 47186 (total 2)
Mar  8 06:04:08.199: VPDN Failed to get session from socket handle 000018FA
Mar  8 06:04:08.199: PPTP:(Tnl0:Sn43450)L2X s/w switching session unprovisioned
L2X_ADJ: Vi1:removed ctx
Mar  8 06:04:08.199: L2X:Session DB (Tnl/Sn: 0/43450): Removed the switching session from the session DB
Mar  8 06:04:08.203: Vi1 PPP: ppp_sip_switching_cleanup
Mar  8 06:04:08.203: Vi1 PPP: old[Down] event[DeEncap] state[Init]
Mar  8 06:04:08.519: Vi2 PPP: Update queued IPCP code[1] id[1]
Mar  8 06:04:11.519: Vi2 PPP: Update queued IPCP code[1] id[1]
Mar  8 06:04:12.527: Vi2 AUTH: Timeout 1
Mar  8 06:04:12.527: Vi2 MS-CHAP-V2: O CHALLENGE id 2 len 34 from "90.157.26.245"
Mar  8 06:04:14.519: Vi2 PPP: Update queued IPCP code[1] id[1]
Mar  8 06:04:17.519: Vi2 PPP: Update queued IPCP code[1] id[1]
Mar  8 06:04:20.519: Vi2 PPP: Update queued IPCP code[1] id[1]
Mar  8 06:04:22.543: Vi2 AUTH: Timeout 2
Mar  8 06:04:22.543: Vi2 MS-CHAP-V2: O CHALLENGE id 3 len 34 from "90.157.26.245"
Mar  8 06:04:23.515: Vi2 PPP: Update queued IPCP code[1] id[1]
Mar  8 06:04:26.515: Vi2 PPP: Update queued IPCP code[1] id[1]
Mar  8 06:04:29.515: Vi2 PPP: Update queued IPCP code[1] id[1]
Mar  8 06:04:32.515: Vi2 LCP: I TERMREQ [Open] id 5 len 4
Mar  8 06:04:32.515: Vi2 PPP DISC: Received LCP TERMREQ from peer
Mar  8 06:04:32.515: PPP: NET STOP send to AAA.
Mar  8 06:04:32.519: Vi2 PPP: Phase is TERMINATING
Mar  8 06:04:32.519: Vi2 LCP: O TERMACK [Open] id 5 len 4
Mar  8 06:04:32.519: Vi2 LCP: Event[Receive TermReq] State[Open to Stopping]
Mar  8 06:04:32.519: PPTP tnl   02905:________: CC I msg 13 for unknown session
Mar  8 06:04:32.719: PPTP tnl   02905:________: StopCCRQ -> state change estabd to idle
Mar  8 06:04:32.719: PPTP tnl   02905:________: Shutting down tunnel
Mar  8 06:04:32.719: L2TUN APP: handle/6401Free switch hdl 10499
Mar  8 06:04:32.719: L2TUN APP: handle/6401shutdown app session
Mar  8 06:04:32.723: PPTP _____:02905:________: close -> state change estabd to wt-cdn
Mar  8 06:04:32.723: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di0
Mar  8 06:04:32.723: Vi2 PPP: Block vaccess from being freed [0x10]
Mar  8 06:04:32.723: PPTP       _____:________: Event tcp-disc was illegal in old state
Mar  8 06:04:32.727: Vi2 PPP: Sending cstate DOWN notification
Mar  8 06:04:32.727: Vi2 PPP: Processing CstateDown message
Mar  8 06:04:32.727: Vi2 PPP: Received graceful disconnect from SIP
Mar  8 06:04:32.727: Vi2 LCP: Event[CLOSE] State[Stopping to Closing]
Mar  8 06:04:32.727: Vi2 PPP: ppp_sip_switching_cleanup
Mar  8 06:04:32.727: Vi2 PPP: Change SIP state from Init to Down
Mar  8 06:04:32.727: Vi2 PPP: old[Up] event[CstateDown] state[Down]
Mar  8 06:04:32.727: Vi2 LCP: Event[DOWN] State[Closing to Initial]
Mar  8 06:04:32.727: Vi2 PPP: Clearing AAA Unique Id = 5C
Mar  8 06:04:32.727: Vi2 PPP: Unlocked by [0x10] Still Locked by [0x0]
Mar  8 06:04:32.727: Vi2 PPP: Free previously blocked vaccess
Mar  8 06:04:32.727: PPTP:(Tnl0:Sn23207)Vi2 Block vaccess from being freed.
Mar  8 06:04:32.727: Vi2 PPP: Phase is DOWN
Mar  8 06:04:32.731: Vi2 PPP SIP segment: Unprovision
Mar  8 06:04:32.731: Vi2 PPP SIP segment: CLEANUP
Mar  8 06:04:33.723: Vi1 PPP: Change SIP state from Init to Down
Mar  8 06:04:33.723: Vi1 PPP: old[Init] event[Encap] state[Down]
Mar  8 06:04:33.723: Vi1 PPP: ppp_sip_switching_cleanup
Mar  8 06:04:33.723: Vi1 PPP: Change SIP state from Init to Down
Mar  8 06:04:33.723: Vi1 PPP: old[Down] event[Encap] state[Down]
L2X_ADJ: Vi1:midchain adj repopulate, nothing to do
Mar  8 06:04:33.723: L2TUN APP: handle/6409Peer AIE:00000000 Peer-peer 00000000 Ours 00000000
Mar  8 06:04:33.723: L2TUN APP: handle/6409New peer; get switch hdl 0
Mar  8 06:04:33.723: L2TUN APP: handle/6409Allocate switch hdl 6411
Mar  8 06:04:33.727: L2X        _____:________: DB: adding cc with id 4466 (total 2)
Mar  8 06:04:33.727: L2X        _____:________: DB: added cc with id 4466 (total 3)
Mar  8 06:04:33.727: PPTP tnl   0190D:________: Tunnel created; we initiated
Mar  8 06:04:33.727: L2X        _____:________: DB: added session (cc id 4466, sess id 44026) (total 1)
Mar  8 06:04:33.727: L2X        _____:________: DB: added session id 44026 into flat id space (total 2)
Mar  8 06:04:33.727: L2X        _____:________: l2x_open_socket: is called
Mar  8 06:04:33.727: PPTP tnl   0190D:________: new-sess -> state change idle to wt-cnnct
Mar  8 06:04:33.727: PPTP tnl   0190D:________: TCP active opening to 10.0.0.1
Mar  8 06:04:33.727: L2X        _____:________: l2x_open_socket: is called
Mar  8 06:04:33.727: PPTP tnl   0190D:________: tcp-conn -> state change wt-cnnct to wt-sccrp
Mar  8 06:04:33.731: PPTP       _____:________: L2X DB: no id
Mar  8 06:04:33.731: PPTP tnl   0190D:________: I SCCRP from local
Mar  8 06:04:33.731: PPTP tnl   0190D:________: protocol version 100
Mar  8 06:04:33.731: PPTP tnl   0190D:________: result code 1
Mar  8 06:04:33.731: PPTP tnl   0190D:________: error code 0
Mar  8 06:04:33.731: PPTP tnl   0190D:________: framing caps 3
Mar  8 06:04:33.731: PPTP tnl   0190D:________: bearer caps 3
Mar  8 06:04:33.731: PPTP tnl   0190D:________: max channels 1
Mar  8 06:04:33.731: PPTP tnl   0190D:________: firmware rev 1
Mar  8 06:04:33.731: PPTP tnl   0190D:________: hostname "local"
Mar  8 06:04:33.731: PPTP tnl   0190D:________: vendor "cananian"
Mar  8 06:04:33.731: PPTP tnl   0190D:________: SCCRP-ok -> state change wt-sccrp to estabd
Mar  8 06:04:33.731: PPTP _____:0190D:________: tnl-up -> state change wt-tun to wt-ocrp
Mar  8 06:04:33.735: PPTP _____:0190D:________: OCRP-ok -> state change wt-ocrp to estabd
Mar  8 06:04:33.735: L2X        _____:________: DB: added session: rIP 10.0.0.1, rSession id 19352 (total 2)
Mar  8 06:04:33.735: PPTP _____:_____:________: L2X session data plane setup successful
L2X_ADJ: Vi1:allocated ctx, size 1
Mar  8 06:04:33.735: PPTP:(Tnl0:Sn44026)L2X setup idb switching
Mar  8 06:04:33.735: L2X:Session DB (Tnl/Sn: 0/44026): Stored the switching session in the session DB
Mar  8 06:04:33.735: PPTP:(Tnl0:Sn44026)L2X s/w switching session provisioned
L2X_ADJ: Vi1:midchain adj repopulate, nothing to do



08 мар 2019, 09:30
Профиль Отправить email

Зарегистрирован: 03 мар 2019, 11:25
Сообщения: 33
Вот спросишь - и сразу сам решишь...

Короче, лишней была хрень
ppp authentication ms-chap-v2
оказывается это не задание типа авторизации с подключающейся строны. А требование для стороны, к которой подключаешься, выполнить обратную авторизацию. Вот ведь хрень.

Код:
interface Dialer0
 description Rostelecom ISP
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 shutdown
 dialer pool 1
 dialer idle-timeout 0
 dialer string 123
 dialer persistent
 dialer vpdn
 ppp chap hostname 90.157.26.245
 ppp chap password 0 XXXXXXXXX
 no cdp enable


08 мар 2019, 14:28
Профиль Отправить email
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 2 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: Google [Bot], root99 и гости: 21


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB