Сообщения без ответов | Активные темы Текущее время: 27 фев 2024, 13:09



Ответить на тему  [ Сообщений: 8 ] 
Catalyst 3560 route-map 
Автор Сообщение

Зарегистрирован: 29 авг 2023, 09:58
Сообщения: 3
Здравствуйте!
Ус-во Catalyst 3560. Надо часть подсетей отправить по разным маршрутам.
Подсеть 1.0, 2.0 и 3.0 отправить по дефолту на 10.0.0.35
Подсеть 4.0 и 5.0 отправить на 10.0.0.34

Пытаюсь сделать через route-map

route-map inetbeel permit 10
description ROUTE_TO_BEELINE
match ip address route_beeline
set ip next-hop 10.0.0.34

ip access-list extended route_beeline
permit ip 192.168.4.0 0.0.0.255 any
permit ip 192.168.5.0 0.0.0.255 any

interface Vlan10
description Internet
ip address 10.0.0.33 255.255.255.248

interface Vlan12
description LAN
ip address 192.168.1.1 255.255.255.0
ip address 192.168.2.1 255.255.255.0 secondary
ip address 192.168.3.1 255.255.255.0 secondary
ip address 192.168.4.1 255.255.255.0 secondary
ip address 192.168.5.1 255.255.255.0 secondary
ip policy route-map inetbeel

ip route 0.0.0.0 0.0.0.0 10.0.0.35

Маршрут для сетей 4.0 и 5.0 отрабатывает и маршрутизирует на 10.0.0.34, все прекрасно!
Маршрут для сетей 1.0, 2.0 и 3.0 отрабатывает и маршрутизирует на 10.0.0.35 (default), все прекрасно!
НО, при пинге между подсетями на интерфейсе Vlan12 трафик также уходит на маршрут указанный в route-map и возвращается обратно.

Пример: tracert с узла 192.168.5.2 до узла 192.168.1.2
192.168.5.1
10.0.0.34
10.0.0.33
192.168.1.2

Как можно избавиться от маршрутизации "directly connected" подсетей ?
Спасибо за помощь!


Вложения:
shema_cat_pbr.jpg
shema_cat_pbr.jpg [ 19.65 КБ | Просмотров: 27952 ]
30 авг 2023, 10:54
Профиль

Зарегистрирован: 08 май 2013, 06:36
Сообщения: 322
sashulka писал(а):

ip access-list extended route_beeline
permit ip 192.168.4.0 0.0.0.255 any
permit ip 192.168.5.0 0.0.0.255 any

Как можно избавиться от маршрутизации "directly connected" подсетей ?
Спасибо за помощь!


Код:
ip access-list extended route_beeline
 ->deny ip 192.168.4.0 0.0.1.255 192.168.0.0 0.0.255.255<-
 permit ip 192.168.4.0 0.0.0.255 any
 permit ip 192.168.5.0 0.0.0.255 any

не помню конкретно по этой модели, на каких-то deny в рм не программируются в tcam чтоли и обработка уходила на cpu


30 авг 2023, 11:40
Профиль

Зарегистрирован: 29 авг 2023, 09:58
Сообщения: 3
Да, при выставлении deny все умирает, консоль еле еле отвечает
значит route-map здесь не вариант


30 авг 2023, 13:36
Профиль

Зарегистрирован: 08 май 2013, 06:36
Сообщения: 322
ну можно теоретически acl 0/0-RFC1918(или только 192.168/16) накидать одними пермитами, но строк побольше будет
а без рм в одном bd все эти сетки не представляю как раскидывать, по-хорошему побить на вланы/врф и ликать то, что нужно


30 авг 2023, 15:56
Профиль

Зарегистрирован: 29 авг 2023, 09:58
Сообщения: 3
не могу сообразить как?
мне ведь наоборот надо запретить роутить на 192.168.


30 авг 2023, 16:14
Профиль

Зарегистрирован: 08 май 2013, 06:36
Сообщения: 322
sashulka писал(а):
не могу сообразить как?
мне ведь наоборот надо запретить роутить на 192.168.

ну да, но если разрешить условно "все", но где не будет 192.168* то смысл то один и тот же
0.0.0.0/1 + 128.0.0.0/2 + + итд


30 авг 2023, 17:25
Профиль

Зарегистрирован: 07 сен 2014, 02:54
Сообщения: 548
Откуда: Msk
ikiliikkuja писал(а):
ну можно теоретически acl 0/0-RFC1918 (или только 192.168/16) накидать одними пермитами ...

А не прокатит ли тут такой финт:
Сделать bypass локального трафика через permit?
Т.е. как-то пропустить локальный трафик в обычный роутинг (GRT).

Код:
ip access-list extended Local_Traffic
  permit ip any 192.168.0.0 0.0.255.255

route-map inetbeel permit 10
  description Local Traffic Bypass
  match ip address Local_Traffic
  set ip next-hop <Local_Interface_IP>  or do Something or do Nothing

route-map inetbeel permit 20
  description ROUTE_TO_BEELINE
  match ip address route_beeline
  set ip next-hop 10.0.0.34

_________________
Knowledge is Power


10 сен 2023, 22:50
Профиль

Зарегистрирован: 08 май 2013, 06:36
Сообщения: 322
Silent_D писал(а):
route-map inetbeel permit 10
description Local Traffic Bypass
match ip address Local_Traffic
set ip next-hop <Local_Interface_IP> or do Something or do Nothing

route-map inetbeel permit 20
description ROUTE_TO_BEELINE
match ip address route_beeline
set ip next-hop 10.0.0.34

ну теоретически можно попробовать, в seq 10 set nh точно лишнее, надо же просто пропускать как есть


11 сен 2023, 09:51
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 8 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 5


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB